question

BrandonNeal-2303 avatar image
0 Votes"
BrandonNeal-2303 asked BrandonNeal-2303 commented

unable to access Azure VM from Public IP address

Created a new VM in Azure with a Public and Private IP address.
Network Rules showing ALLOW SSH port 22 for inbound traffic.
Utilizing powershell: ssh -i .\<public key> username@publicIPaddress - connection time out
Using putty to SSH does not connect.
Tested with IP Flow showed no issues.
Did a redeploy of the VM.

Any assistance would be greatly appreciated.

Thanks,

azure-virtual-machines
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

PradeepKommaraju-MSFT avatar image
0 Votes"
PradeepKommaraju-MSFT answered BrandonNeal-2303 commented

Hello @BrandonNeal-2303

Thank you for reaching out to Microsoft Q & A Platforms ,

Did you try to perform reset configuration using azure portal ?

Please try to run through the in detailed troubleshooting steps as mention in https://docs.microsoft.com/en-us/troubleshoot/azure/virtual-machines/troubleshoot-ssh-connection
Which would help you in resolving the issue .

Request you to accept the answer if this helped in fixing your issue .

Thanks & Regards ,
Pradeep

· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Good morning Pradeep,

Thank you for reaching out. At this time, this did not resolve the issue. Here are my notes.

Reset SSH configuration
Reset SSH credentials (using private key vs. public - was unable to do this but this should not matter with not even establishing a connection and getting time out)
Check security rules ( verified I can access port 22 from outside world to VM )
Check routing - confirmed next hop
Azure VM Console - Diagnostics tool ran but nothing round
Use Azure Bastion to confirm SSH is running on port 22

I have also completed a redeploy of the VM. I also deleted the VM and all items with it, created a new VM with a different public IP address with same settings.

Effective routes are not showing forced tunneling.

I believe the issue is with the Public IP address and why I am not able to connect to it from the outside world - or if there is routing that is not allowing me to access that public IP address.

Any other thoughts?

0 Votes 0 ·

Thanks for the response Brandon ,

It would be interesting to know the following to understand this issue further :
1) Can you explain me the source of this connection from{From where are you trying to connect/SSH to this VM}
2) If this is from an On-prem server , How are you connected to Azure , VPN tunnel / Express rote ?
3) Did you try to ping the Pubilc Ip address of the VM from anywhere outside and what is the result of the same ?
4) Do you also have few other VM's with in the same VNET/SUBNET which work as well ?

Thanks & Regards,
Pradeep

0 Votes 0 ·

1) The source of my connection is my work latpop.
2) This is not an on-prem server. This VM was created in Microsoft Azure. Currently in a hybrid solution utilizing an on-premise VPN with an Express Route to our Azure environment. Disconnecting from the VPN provides the same results.
3) Ping is currently turned off by default. I created a port rule to allow ICMP and the pings were unsuccessful.
4) Only two resources in that VNET have public IP addresses.

Questions:
1) Would moving to a different VNET be a good test?
2) Even though a public IP address, is there specific routing that needs to be in place to access those public IP addresses within either VNET? Currently using Checkpoint Cloudguard and in the process of finishing configuration, but with a public IP address it should still be accessible.. correct?

Thanks,
Brandon

0 Votes 0 ·
Show more comments