question

EthanMatthews-5171 avatar image
0 Votes"
EthanMatthews-5171 asked amanpreetsingh-msft commented

Re-register MFA not forcing a user to change their authentication method, still defaulting to old method when logging in.

Having some issues with the MFA re-register button in the Azure AD admin portal where the button is not doing what it should. This has happened recently for a couple users. I was originally thinking it was something that needed to be synched, but after 12 or so hours of it still not working I believe that is no longer the case. Is there another way to re-require MFA within the portal itself?

azure-ad-multi-factor-authentication
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

amanpreetsingh-msft avatar image
0 Votes"
amanpreetsingh-msft answered amanpreetsingh-msft commented

Hi @EthanMatthews-5171 • Thank you for reaching out.

There is no other way to re-require MFA within the portal but you can use PowerShell cmdlet for this purpose, as mentioned below:

  1. Run Install-Module MSOnline from elevated PowerShell (run as administrator) to install the required module.

  2. Run Connect-Msolservice and sign-in using Global Administrator/Privileged Authentication Administrator account.

  3. Run Set-MsolUser -UserPrincipalName username@your_tenant.onmicrosoft.com -StrongAuthenticationMethods @() to require given user to re-register for MFA.


Please "Accept the answer" if the information helped you. This will help us and others in the community as well.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@EthanMatthews-5171 • Just checking if you had a chance to test it out.

0 Votes 0 ·