question

LorenzoFongaro-0341 avatar image
0 Votes"
LorenzoFongaro-0341 asked GaryReynolds answered

Windows 2019 gpresult /h AD / SYSVOL Version Mismatch

Hello.

I'm trying to understand how to solve this issue: some GPO are not applied to some server due to a AD / SYSVOL Version Mismatch.

I'm looking for a solution for Windows 2019.
The only solution I found is about Windows 8.1 or Windows 2012: it's about a fix to install, but I use Windows 2019, not 2012.

145854-clipboard01.jpg


windows-active-directorywindows-server-2019
clipboard01.jpg (16.5 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

DSPatrick avatar image
0 Votes"
DSPatrick answered

Not a lot to go on but you could try a non authoritative synchronization for
https://support.microsoft.com/en-us/help/2218556/how-to-force-an-authoritative-and-non-authoritative-synchronization-fo

Also note the two prerequisites to introducing the first 2019 domain controller are that domain functional level needs to be 2008 or higher and older sysvol FRS replication needs to have been migrated to DFSR
https://techcommunity.microsoft.com/t5/Storage-at-Microsoft/Streamlined-Migration-of-FRS-to-DFSR-SYSVOL/ba-p/425405

--please don't forget to upvote and 145510-image.png if the reply is helpful--








5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

GaryReynolds avatar image
0 Votes"
GaryReynolds answered

Hi @LorenzoFongaro-0341

The error/warning is caused because the versions numbers of the GPT and GPC components of the GPO don't match. The GPT version number is stored in the AD against the GPO object and the GPC version number is stored in the gpt.ini in the sysvol share.

Normally as you edit the policy these numbers are incremented and is used to confirm that the GPT and GPC are in sync. For some reason the version number on this policy don't match, hence the warning.

The easy way to fix this is, is to edit the policy again, by adding and removing a setting, this will cause the version numbers to be updated and should sync the GPT and GPC version numbers.

Gary.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.