Outlook application not displaying photos

Mackenzie Miller 1 Reputation point

Good morning,

I have been struggling with this issue for a few days now. I have created a mail flow rule that appends a disclaimer to my emails sent using HTML code in lieu of a signature block configured directly on the Outlook application. When I see the signature that is appended to the email, it shows the following:

I thought something was wrong with the code, but when I check the email with the browser based Outlook, it looks fine, same with the mobile version. I have tried sending it to other people and it doesn't the image either on the Outlook application. I have looked online to see if there are any other settings on the application I could check that would fix this, but none have worked so far, including changing the registry value of the blockHTTPS or whatever it is (the value wasn't even there).

Any advice on this would be appreciated. If it is an Exchange server issue, I don't know where to look to check that. Thanks for your help.

Outlook Management
Outlook Management
Outlook: A family of Microsoft email and calendar products.Management: The act or process of organizing, handling, directing or controlling something.
3,424 questions
Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
6,085 questions
No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Yuki Sun-MSFT 24,606 Reputation points

    Hi @Mackenzie Miller ,

    I just tried testing in my Exchange 2019 lab environment with the html code below, the image(I used the image you shared above in the post.) can show properly in Outlook 2019 desktop client:

    <IMG src="/api/attachments/145871-image.png"?platform=QnA alt="Contoso logo">


    Would you mind have a check and see if you are using the same <IMG> tag to point to the image available on the Internet? Or you can remove all personal information involved, including the image url, then share a snippet of the html code you used, and I'll see if I can reproduce the issue using your code.

    Besides, it's recommended to have a go on one of the Outlook desktop clients, go to File > Options > Trust Center > Trust Center Settings > Automatic Download, clear the checkbox of "Don't download pictures automatically in standar HTML email messages or RSS items"and see if it can be of some help:

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.