question

gayanguna-6901 avatar image
0 Votes"
gayanguna-6901 asked CaseyYangMSFT-4714 commented

SharePoint 2013 people search not working after user principal name changed in active directory

Recently we have changed user principal name in active directory and since then SharePoint people search has been stopped working. We checked log files and found no error messages. Also checked search service as well. We ran full user profile synchronization task and full crawl in people search content source but didn't fix the issue. Appreciate if someone can assist us to figure this issue out.

office-sharepoint-server-administrationsharepoint-devoffice-sharepoint-server-developmentoffice-sharepoint-server-itprooffice-sharepoint-server-search-itpro
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

CaseyYangMSFT-4714 avatar image
0 Votes"
CaseyYangMSFT-4714 answered CaseyYangMSFT-4714 commented

Hi @gayanguna-6901,

You could try the following steps to troubleshoot.

1.Set the permissions for the search crawler to Retrieve People Data.
Application Management > Manage service applications > Select the User Profile Service Application line > Administrators >Add the Default content access account > make sure that Retrieve People Data for Search Crawlers is checked

2.Make sure you type the sharepoint://hostname into the content sources.

3.Create a crawl rule. Go to Search Administration -> Crawl Rules -> Add Crawl Rule.

For Reference: SharePoint 2013: People Search Not Working


If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @gayanguna-6901,

I'm checking how the things are going on about this issue. Is there any progress on this issue?

0 Votes 0 ·

Hi Casey,

Sorry for late response. Was busy with some other issues. Actually I checked the settings you have mentioned but those settings are fine there. Still we have this issue. Anyway I will update the status and progres.

Thanks.

0 Votes 0 ·

Hi @gayanguna-6901,

Did you configure the user profile synchronization by using SharePoint Active Directory Import?

0 Votes 0 ·
Show more comments
sadomovalex avatar image
0 Votes"
sadomovalex answered gayanguna-6901 edited

did you change principal name of the user account which is used by search crawler? If yes you should also reconfigure default account for crawling in Central administration: Change the default account for crawling in SharePoint Server.


· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi Sadomovalex,

Thanks for the response. As per our IT teams response, yes the user principal name has been changed for all the users in domain. As you have instructed, After the default account for crawling is changed, do we have to run a full crawl on content source related to people search (my site)?

Thanks

0 Votes 0 ·