WIndows server 2016 NPAS(IAS) service cannot start after change to different hypervisor

asked 2021-11-03T06:45:18.977+00:00
Rafalefighter 1 Reputation point

Hi All,

Recently we migrated our windows servers to different hypervisor platform on the same hardware. Initially we had issues with windows activation but now it activated. For some reason IAS service cannot get started on one of the server and all wifi authentication not working due to this.

when I tried to start NPAS from server manager I'm getting bellow error

Service IAS cannot be started

I did few troubleshooting steps after this without any luck

I edit the C:\Windows\System32\ias folder permission and gave full access to the NETWORK SERVICE user.

Also tried the Registry fix mentioned here https://techcommunity.microsoft.com/t5/windows-server-essentials-and/the-network-policy-server-service-ias-fails-to-start-or-be/ba-p/396769

Also below command

sc config "IAS" type= own

There is no detailed errror message on Event viewer under the Network Policy and Access Service. but in the windows logs > system I found below error with 7000

The Network Policy Server service failed to start due to the following error:
The service start failed since one or more services in the same process have an incompatible service SID type setting. A service with restricted service SID type can only coexist in the same process with other services with a restricted SID type. If the service SID type for this service was just configured, the hosting process must be restarted in order to start this service.

At this point I'm not sure what is the exact error causing this issue. Migration done by copying block level qcow images to new hypervisor and non of the OS level configurations are changed.

Windows Server 2016
Windows Server 2016
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
1,750 questions
No comments
{count} votes