Activating Virtual Computer Platform renders my computer unable to boot

Nicolas Sylvestre 1 Reputation point


I'm a student in computer science and tried to setup WSL2 to use the CUDA Library.
I'm already using WSL1 and need to upgrade to be able to use the graphic card.

My issue is that when i manually activate the "Virtual Computer Platform", under Hyper V, my computer doesnt reboot. What I mean by that is that the asus logo is showing up, the little circle is going round and then a black screen appears and nothing happens.

My solutions to make my pc boot again was either to force shutdown it three times to get the repair tool and repair it from there (worked the 1st, 2nd and 4th time), or to fully reset it and reinstall windows (that was a bit of a pain).

My specs :

  • Windows Home Version : 21H1 19043.1320
  • Processor : AMD Ryzen 5 3550H
  • RAM : 16Go
  • NVIDIA GeForce GTX 1650
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
1,949 questions
No comments
{count} votes

2 answers

Sort by: Newest
  1. MailSmk4me 1 Reputation point

    Basic hardware requirements are as follows:

    • 64-bit Processor with Second Level Address Translation (SLAT).
    • CPU support for VM Monitor Mode Extension (VT-x on Intel CPU's).
    • Minimum of 4 GB memory.

    Also, check these options:



    In general, ASUS laptops for computer science student is a reasonable choice. As virtual machines share memory with the Hyper-V host, you will need to provide enough memory to handle the expected virtual workload.

  2. Limitless Technology 37,641 Reputation points

    Hi there,

    First thing first, Confirm That Your Hardware Supports Virtualization

    In most cases where virtualization won't work, even if your CPU supports it, the cause is that you have the feature disabled in your computer's BIOS or UEFI.

    Type cmd into the Start menu to launch a Command Prompt window, then type systeminfo and hit Enter. After a moment, you'll see a lot of info about your computer. Scroll to the bottom and next to Hyper-V Requirements, you'll see a Virtualization Enabled In Firmware field.

    If none of them is helpful, try disabling Hyper-V and let your computer run your virtualization app of choice without conflict.

    --If the reply is helpful, please Upvote and Accept it as an answer--