Unable to install IIS Feature on Server 2019

asked 2021-11-08T16:25:37.89+00:00
Chris Youngblut 1 Reputation point

Hello,

I've been trying to install The IIS feature on a MS Server 2019 machine. The install runs for a bit but then stops and tells the operation cannot be completed becasue the server you specified requires a restart. I've also tried testing other features such as DHCP - DHCP feature installs ok, but now it won't let me remove it - Error 0x800f0922. I've run SFC /Scannow as well as the DISM tool. Have found no issues with the server. Have rebooted many times. Have tried both domain administrator login and local administrator login to install.

anything else to try before i completely rebuild this server?

Thanks

Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
2,178 questions
No comments
{count} votes

2 answers

Sort by: Most helpful
  1. answered 2021-11-08T16:34:31.277+00:00
    Dave Patrick 328.4K Reputation points Microsoft MVP

    0x800f0922 == CBS_E_INSTALLERS_FAILED You can try routing around in \dism.log, \cbs.log, \windowsupdate.log files for clues but time may be better spent standing up a new one, patch fully, and try again to add roles.

    --please don't forget to upvote and Accept as answer if the reply is helpful--


  2. answered 2021-11-09T23:22:05.077+00:00
    Ronald Carter 1 Reputation point

    I would recommend a fresh install. If this is a new VM you shouldnt be having these issues.

    Was it deployed from a template? WDS? SCCM?

    No comments