question

hillarysagwa-3428 avatar image
0 Votes"
hillarysagwa-3428 asked hillarysagwa-3428 commented

Blazor web assembly doesnt run on mobile browser after upgrade to .net 6

I have a blazor web assembly app in production. performance on mobile phone browsers has been really bad and I have been eagerly waiting for .net 6 so us to benefit from the performance benefits coming with it. however when I upgraded to .net 6 yesterday after it was officially released. it runs well on a computer but fails to run on mobile phones. I am unable to see where the error is coz the mobile phone browsers have poor developer tool.
why is this happening to my app?
www.unifiedmall.co.ke


this is the URL to the app. it only opens on a computer.

dotnet-aspnet-core-blazor
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

ADefWebserver avatar image
0 Votes"
ADefWebserver answered hillarysagwa-3428 commented

it runs on my Edge web browser on my Samsung 8.
Also be aware that if you remove the https and the www. from you web address you are showing your website directory.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

thank you for responding. I usually test it on my infinix smart 5 and my wife's Tecno Pouvoir 3 Air using both chrome and Firefox browser. when they both fail i make an assumption that it wont run on any other smartphone. i ve had to uninstall '.net WebAssembly build tools' from visual studio then publish again. now its running well. i dont know why this solution has worked

1 Vote 1 ·