Internet Explorer 8 acting strange on Windows 7 unable to connect when other browsers are fine

David Williams 21 Reputation points

I am having some real issues with Windows 7 Premium running on an HP Pavillion Lap top. The Laptop has worked fine for years until the other day when I decided to upgrade to Office 365. The install went without a hitch, however I was unable to activate the license with a message appearing telling me there was a problem with the server and to try again later. I was unable to activate it and eventually the grace period ran out. I usually use Firefox but decided to remove it during my spring clean so using Explorer 8 I tried to access, it was then that I realized that everything was acting weird, and explorer wouldn't display the page correctly, instead showing some half hitched (almost safe mode) version of the site with no formatting and none of the (javescript) type links working.

After hours of playing around I decided to use the HP support software and carried out a complete system rebuild back to factory settings including reinstalling all the drivers etc..

Once completing the windows welcome to your new PC setup I proceeded the the windows update module so I could bring the installation up to date. When clicking on 'Check for updates' I get an error 'Windows could not search for new updates' An error occurred while checking for new updates for your computer. Error(s) found Code 80072EFE Windows Update encountered an unknown error.

Once again it looked like windows itself was unable to make a connection to the internet despite a good wireless connection that I know works with other PC's on the network.

I tried Internet Explorer again and exactly the same thing happened: the initial MSN home page displayed perfectly but as soon as I tried to access I got half an formatted page appearing and the 'sign in' link would not work. I tried other popular websites and mostly got 'Internet Explorer cannot display the webpage' with the option to diagnose the connection problems. When clicking this button Troubleshooting couldn't identify the problem.

I managed to download chrome (yes, google web page would load)! When running chrome I was able to access all websites including Microsoft, however what was weird is that the 'sign in' button (top right) was disabled and I was unable to login to my microsoft account.

I tried to upgrade explorer to edge (yes, managed to just about get to the link) the installation started perfectly until Edge told me that something went wrong and it couldn't connect to the internet and the installation stopped.

In a nutshell, it looks like my computer is unable to communicate with microsoft correctly, meaning no windows updates, no activating office 365, windows explorer acting strangely and other browsers working fine but not allowing me to click on the sign in button in microsoft.

I've dealt with a million different problems with Windows over the last 30 years but never seen anything like this, it just defies all logic!

I thought I would see if anyone out there had any idea's before I through away what seems to be a perfectly good laptop!

Before replying, please bare in mind that I have reset everything with a completely fresh install (formatting 'c' drive and starting again), so there is no browser history to clear or cache to reset. I'm sure the problem runs far deeper than those simple suggestions.

I am reluctant to pay and upgrade to Windows 10 with fear of the problem still being the same.

Suggestions welcome.... Thanks

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
25,339 questions
No comments
{count} votes

0 additional answers

Sort by: Most helpful