OneNote Default Save Location GPO - Not working

asked 2021-11-12T03:25:46.873+00:00
lisagenix 1 Reputation point

I've set the default Save location for OneNote and I can see the value reflected in the registry which should just be %userprofile%\onedrive - Company.

However the settings that show up in OneNote are c:\users\username\onedrive\documents\%userprofile%\OneDrive - Compnay\MyNotebook.

It's just appending my settings to the default location rather than replacing it, can I get some assistance as to why this isn't working?

Windows Group Policy
Windows Group Policy
A feature of Windows that enables policy-based administration using Active Directory.
1,864 questions
OneNote Management
OneNote Management
OneNote: A family of Microsoft products that enable users to capture, organize, and reuse notes electronically.Management: The act or process of organizing, handling, directing or controlling something.
128 questions
No comments
{count} votes

3 answers

Sort by: Most helpful
  1. answered 2021-11-12T08:50:47.727+00:00
    Emily Hua-MSFT 21,526 Reputation points Microsoft Employee

    Hi @lisagenix

    I can reproduce your issue on my environment, it seems that OneNote does not support environment variable "%userprofile%" when setting default locations. Even I add the registry key "notebook root" directly as following image, it still does not work.
    148739-capture51.jpg

    This issue does not occur with Word,
    148824-capture49.jpg

    It's recommended to raise this issue to related Microsoft team.
    148842-capture52.jpg
    To make this vocie louder, I have submited this issue in OneNote app.

    Thanks for your understanding.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



  2. answered 2021-11-12T17:26:28.567+00:00
    Craig Owings 1 Reputation point

    You have to use a REG_EXPAND_SZ type, not a REG_SZ for your notebook root. Just set it using group policy preferences.

    No comments

  3. answered 2021-11-12T19:33:00.447+00:00
    Georg Matviak 166 Reputation points

    Hi lisagenix-4908,

    Thank you for your question and reaching out. My name is Jainth and I’d be more than happy to help you with your query.

    However, to protect your important notes from a serious problem, such as a hard disk failure, consider changing the default location of your OneNote Backup folder.

    Suitable backup locations for your important notes include a folder on a secondary or external hard disk drive, a removable storage device such as a USB drive, or a private folder on your network.

    Change the default location for backup files
    Click File > Options > Save & Backup.

    Under Save, in the Paths list, click Backup Folder, and then click Modify.

    In the Select Folder dialog box, navigate to the location of the folder where you want OneNote to store backup files, and then click Select.

    Also, Do check out the below link for better understanding.

    https://support.microsoft.com/en-us/office/change-the-default-storage-location-for-backup-files-2a35f601-cbc2-46cf-928a-1f30316fb009


    Hope this answers all your queries, if not please do repost back.
    --If an Answer is helpful, please click "Accept Answer" and upvote it--

    No comments