Single member of a group not receiving majority of alert emails sent to this mail enabled security group

Simon Fanning 116 Reputation points
2021-11-18T16:13:32.103+00:00

Hi all,

I hope everyone is keeping well!

I've an issue with a single user account receiving emails sent to a mail enabled security group.
The user is not hidden from the GAL, the outlook cache has been flushed, and outlook profile deleted and recreated to no avail, I have also removed the user account from the security account for over 1 hour then added it back in.. no change there.

Message tracing shows that email is being delivered to other members of the group, but the problem users email address is not even being detected or picked up in order to send an email to them.

It must be an issue within our Exchange environment (Exchange 2013 and EAC).

Any help would be greatly appreciated.. I've been stuck for a couple of days now..

Thank you!

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,227 questions
0 comments No comments
{count} votes

Accepted answer
  1. Simon Fanning 116 Reputation points
    2021-11-22T18:29:50.137+00:00

    Solution:

    It had to do with the manner in which the user account was created. Once the account was created on-prem, and allowed to sync with ExchangeOnline, and then given a license, the user account had no exchange attributes to be managed in the on-prem exchange..

    We basically introduced the account to the On-Prem server and now the user is getting the correct alert emails sent to that mail enabled security group!

    0 comments No comments

4 additional answers

Sort by: Most helpful
  1. Andy David - MVP 138.6K Reputation points MVP
    2021-11-18T17:38:08.267+00:00

  2. Simon Fanning 116 Reputation points
    2021-11-19T17:24:39.647+00:00

    I just ran an extended trace - it took almost 2 hours...

    "The query submitted did not produce any matches."

    No luck here...

    0 comments No comments

  3. Andy David - MVP 138.6K Reputation points MVP
    2021-11-19T17:46:17.9+00:00

    hmm, gonna be tough to troubleshoot if there is nothing in the message tracking logs and its not reproducible at will.

    can you create a new group and use that instead or change the notification to send directly to this user and the group as well?

    0 comments No comments

  4. Simon Fanning 116 Reputation points
    2021-11-22T14:00:32.537+00:00

    Interesting update:

    When the on premise SMTP server is used, the user is not picked up at all.
    When the Exchange online SMTP server is used, all users in the mail enabled security group receive their mail perfectly.

    Simon

    0 comments No comments