Purview integration with Erwin 9.x

Lloyd 111 Reputation points
2021-11-19T16:26:26.05+00:00

Hi all,

Has anyone had any luck integrating Azure Purview with Erwin (Preview) sources yet? When I try to kick off a scan I keep receiving the following error:

Error: (3913) JavaException: Must have Java 8 or newer installed.

It's a pretty self-explanatory with an obvious solution on face-value, however;

  • The server that the SHIR sits on has JDK 17.0.1 installed and configured, with the correct JAVA_HOME and PATH system variables set and validated.
  • The SHIR can connect to other sources on the same network without issue.
  • Previously the same SHIR on the server was used by Data Factory for activities that required Java (i.e. ETL with Parquet). Those activities ran fine, so I know that SHIR can use the Java installation on the server.
  • I have tried multiple SHIRs setups, including SHIRs on-dedicated machines and SHIRs sitting on the Erwin Mart Server (per the pre-requisites). Both setups get the same error.
  • All other Purview --> Erwin pre-requisites are in in place/correct.
  • The Erwin Mart Server I'm using is supported by Purview (v9.7), is running, and the source settings in Purview have been verified as correct.
  • I'm using the latest version of the SHIR
  • Networking considerations have been checked and verified.
  • The SHIR logs don't seem to add anything extra other than the error in question.

So I'm a little stumped on what else to try. It'd be interesting to hear if anyone has seen anything similar?

Cheers

Microsoft Purview
Microsoft Purview
A Microsoft data governance service that helps manage and govern on-premises, multicloud, and software-as-a-service data. Previously known as Azure Purview.
853 questions
{count} votes

Accepted answer
  1. Lloyd 111 Reputation points
    2021-12-02T11:40:16.637+00:00

    Hi @PRADEEPCHEEKATLA-MSFT

    This looks to be fixed now. The short answer is that the Purview preview connector only works with JDK 11 - not higher or lower. The error I received (Error: (3913) JavaException: Must have Java 8 or newer installed.) is therefore a misleading error, likely carried over as-is from Data Factory (which Purview is seemingly built from) and hasn't yet been updated. It should read something like "Requires Java 11 to work".

    For my situation, Erwin has Java 8 included within its package which is why the original error was strange. It's not possible to upgrade that version of Java, so instead I had installed JDK 17 (the latest) for the IR to use. Therefore my fix was to uninstall Java 17 and replace it with Java 11.

    Assumedly once this connector is out of preview then it will support higher/latest versions of Java, but that's the solution for now.

    Regards,

    Lloyd

    1 person found this answer helpful.

0 additional answers

Sort by: Most helpful