Exchange 2016 CU21 update but show the ver. 2242.4

Георгий Гурушкин 1 Reputation point
2021-11-21T21:49:33.393+00:00

Have a good day!

I've got a main domain and 2 subdomains in our organisation. Exchange 2016 CU20 was installed in one subdomain.
All was working perfectly! I've upgraded Exchange to CU21, no mistakes during upgrade! Everything was successfully!
But when I got in ECP - the version of Exchange - was old (2242.4 CU20). Now have problems with new-made mailboxes! Constantly error in sending them emails - no such users!
Before installing in main domain i've done PrepareSchema\AD\Domain; In subdomain, where exchange was - PrepareDomain.
Looking Exchange Organisation Properties (ADSI Edit) - in main domain - old version (SerialNumber - Version 15.1 (Build 32242.8)
In subdomain - new version - Version 15.1 (Build 32308.8) !! AD synhronisation is working! Wthat's the problem?
And how to solve it !!!

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,196 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Zhengqi Lou-MSFT 8,856 Reputation points Microsoft Vendor
    2021-11-22T05:40:49.88+00:00

    Hi @Георгий Гурушкин ,

    Was the DC installed on the main domain?

    And for your situation, you should better use PrepareAllDomains

    I guess the users are on your main domains and that could be the reason you get this error:
    Please check this document and focus on this:
    https://learn.microsoft.com/en-us/exchange/plan-and-deploy/prepare-ad-and-domains?view=exchserver-2016#choose-the-active-directory-domains-to-prepare

    • You need to prepare every domain where an Exchange server will be installed.
    • You need to prepare any domain that will contain mail-enabled users, even if the domain won't contain any Exchange servers.
    • Your account needs to be a member of the Domain Admins group in the domain that you want to prepare.
    • If the domain that you want to prepare was created after you ran /PrepareAD in Step 2, your account also needs to be a member of the Organization Management role group in Exchange.

    You could check the version after preparing all domains and if that shows the old one, please try installing the update again.

    And a suggestion is to install the latest CU22 while not CU21, there are many security patches included in CU22, and better install the latest SU here:
    https://learn.microsoft.com/en-us/Exchange/new-features/build-numbers-and-release-dates?view=exchserver-2019#exchange-server-2016

    Best regards,
    Lou


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Георгий Гурушкин 1 Reputation point
    2021-11-22T14:46:40.81+00:00

    Thank you for the answer very much! Everythin was done, as you describe. I've done it one more time!
    Main domain - no ordinary users, no exchange, it get the Schema !
    First subdomain - all users with mailboxes, two ExchSevers - 2016CU21 (DAG1)
    Second subdomain - a few users with special rights and now without mailboxes (before they where like the first domain users with mailboxes? but now they have the second account on the first subdomain to use mailbox)

    Main domain - /PrepareSchema, /PrepareAD, /PrepareDomain Rights - EntAdmin.
    First, Second subdomains - /PrepareDomain Rights - DomainAdmin

    Nothing changed!

    In main domain - Servers (ADSI Edit) - old version (SerialNumber - Version 15.1 (Build 32242.8))
    First subdomain - Servers (ADSI Edit) - new version - Version 15.1 (Build 32308.8)
    Second subdomain - Servers (ADSI Edit) - old version - Version 15.1 (Build 32242.4)

    Problems with new users whom were made new mailboxes !


  3. Георгий Гурушкин 1 Reputation point
    2021-11-23T06:23:17.84+00:00

    The proble is that our changes in Exchange configurations didn't got into main domain!
    Where to look for the solution

    0 comments No comments