Passing parameters to the Report url not working

Eshwar 196 Reputation points
2021-12-16T14:18:29.863+00:00

HI,
I am trying to pass parameters to the report url but it is not taking and considering it as a report name

Below is I am trying:
http://ReportURL/reports/report/<Folder name>/Workgroup%20Inventory%20Report&rs:Command=Render&PARAM_PERSPECTIVE=ALL

It is showing error as below:
158260-image.png

What is the issue?

Thanks,
Eshwar

SQL Server Reporting Services
SQL Server Reporting Services
A SQL Server technology that supports the creation, management, and delivery of both traditional, paper-oriented reports and interactive, web-based reports.
2,736 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Michael Taylor 44,936 Reputation points
    2021-12-16T15:55:49.647+00:00

    SSRS has 2 ways to programmatically access reports: URL Access and Web Service. It appears you're going to the URL Access route. SSRS also has 2 different endpoints it listens on. The Reports endpoint is for the Report Manager UI. The ReportServer endpoint is for programmatically generating the report.

    If you want to link to the UI with the parameters filled out then the format is this: http://<serverurl>/ReportServer?/<reportpath>&<param>=<value>

    So if your SSRS server is on myreportserver.mycompany.com and the report you want to render is MyReport under the folder MyReports and you have a parameter called PARAM_PERSPECTIVE set to ALL then it would be http://myreportserver.mycompany.com/ReportServer?/MyReports/MyReport&PARAM_PERSPECTIVE=ALL.

    Note that if you're using named instances for SSRS then that gets appended to the ReportServer value. For example if your SSRS instance is called Test then the updated URL would be .../ReportServer_Test?.

    2 people found this answer helpful.

  2. Isabellaz-1451 3,611 Reputation points
    2021-12-17T03:16:41.043+00:00

    Hi @Eshwar

    The fomat is like this:http://<serverurl>/ReportServer?/<reportpath>&<param>=<value>

    I think you probably need to add “?” after the ‘’ReportURL“

    Best Regards,
    Isabella


    If the answer is the right solution, please click "Accept Answer" and upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    2 people found this answer helpful.
    0 comments No comments