Teams for Vdi & Fslogix

asked 2021-12-21T22:40:21.59+00:00
Ahmad Abdulal 26 Reputation points

I am running into a bizarre issue and would appreciate it if anyone can help or shed some lights

Setup

Windows Server 2019 (*X sessions host servers
Office pro plus installed via ODT excluded Teams
Teams for VDI latest version 1.4.0.31569 (latest)
FSlogix as profile container ( Teams included in the profile container)

Issues

Some users sign in this morning, their Teams won't start , error message " We are sorry, we run into an issue"
if you rebuild the fslogix profile the issue get fixe for a day until it happens again
If you delete the contents under %username%\AppData\Microsoft\teams , user can sign in but then it happens again the next time he logins, and sometimes it works for a couple or three days!

I have tried alot of solutions and suggestion but it sounds like a bug to me. I also tried a previous version of Teams for VDI 1.4.00.22472

Anyone

Microsoft Teams
Microsoft Teams
A Microsoft customizable chat-based workspace.
5,272 questions
FSLogix
FSLogix
A set of solutions that enhance, enable, and simplify non-persistent Windows computing environments and may also be used to create more portable computing sessions when using physical devices.
367 questions
No comments
{count} votes

Accepted answer
  1. answered 2021-12-22T02:54:04.46+00:00
    Zhengqi Lou-MSFT 8,796 Reputation points Microsoft Employee

    Hi @Ahmad Abdulal ,

    Please try the following methods:

    1. Create registry entry to prevent users on RDS server from performing workplace AAD joins: HKLM\SOFTWARE\Policies\Microsoft\Windows\WorkplaceJoin,
      “BlockAADWorkplaceJoin”=dword:00000001
    2. Delete/Rename the following folders on the users profile:
      C:\Users\<username>\AppData\Local\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
      C:\Users\<username>\AppData\Roaming\Microsoft\Teams

    Please also make sure you have a copy for the registry.

    And when logging in to the Teams, select Only sign in this application.

    Best regards,
    Lou


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


1 additional answer

Sort by: Most helpful
  1. answered 2021-12-29T08:57:35.91+00:00
    Ahmad Abdulal 26 Reputation points

    HI @Zhengqi Lou-MSFT .

    Thanks for providing the fix!! it seems to be working for me. I am surprised Microsoft support couldn't pick this one up!

    I won't be able to confirm the issue is solved completely for the users since the issue was intermittent and we are middle of Xmas Break but according to my testing, it is working fine.

    I Just need to figure out a way of deleting the mentioned folders for all the users 100+

    I appreciate your help

    Cheers
    AS