question

Andrey-9584 avatar image
6 Votes"
Andrey-9584 asked JV-8089 commented

Microsoft Exchange FIP-FS Scan Engine failed to load after update 01/01/2022 0x80004005 Can't convert to long

Greetings and Happy New Year!

Tpday 01/01/200 faced this issue after auto update the FIP-FS (filtering management service) on our on-premium server MS Exenge 2016 21 KU with the latest security updates (KB5007409).

The FIP-FS "Microsoft" Scan Engine failed to load. PID: ХХХХХ, Error Code: 0x80004005. Error Description: Can't convert "2201010001" to long. (2201010002, 2201010003 etc)

Since the service is interconnected with the transport service, mail stops coming in and out, respectively.

And yes, as a workaround, disabling Disable-AntimalwareScanning.ps1 helps

office-exchange-server-administrationoffice-exchange-server-mailflowoffice-exchange-server-connectivity
· 10
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Exactly the same issue here. Got called out at 7AM to issues with email delivery. I'm logging with Microsoft support.

3 Votes 3 ·

Having the same issue!!!! Please keep this post updated! Thanks in advance!

0 Votes 0 ·

Can't convert "2201010001" to long looks like a version number including the date (20)22.01.01.0001 ... as max-long is 2147483647 it worked for (20)21.12.31.xxx but not for (20)22.01.01.0000
Fits the first Log entry today at 02:20 am :(

As mentioned Disable-AntimalwareScanning.ps1 helps

0 Votes 0 ·

We have had the same issue for the last 6 hours, had tried everything spoken about here but our mail Q's kept on building. It also turns out you need to check for any Transport rules that may check mails for Credit card numbers, attachments as they use the same engine, disable these and mail will work.

1 Vote 1 ·

Exchange 2019 as well.
Thanks for the heads up!

0 Votes 0 ·

I too am having the issue. Exchange 2016

0 Votes 0 ·

same issue here. Disabling malware scanning works and queues have come down but they are not clearing completely with an average of 70 mails still stuck in the submission queue on each of the 3 servers for this client and experiencing mail delays because of this. Works fine at another client i must add.

0 Votes 0 ·

queue suspend and resume will help here:

Get-Queue | Get-Message | Suspend-Message

Get-Queue | Get-Message | Resume-Message

0 Votes 0 ·
Show more comments
CorbettEnders-5651 avatar image
2 Votes"
CorbettEnders-5651 answered KozerskiRaffael-2722 commented
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

yes, the "ResetScanEngineVersion.ps1" worked like a charme. After running and downloading the new Malware ScanEngine I enabled the Malware ScanEngine and everything works fine (Exchange 2016).
Thanks to all! Raffael

0 Votes 0 ·
JV-8089 avatar image JV-8089 KozerskiRaffael-2722 ·

Did you have to put in maintenance mode? I think it just restarts the transport and then the Filtering management service?

0 Votes 0 ·

No maintenance mode (only single mailbox server); the script stops and starts FMS and Transport Services.

1 Vote 1 ·
BrandonC-4585 avatar image
1 Vote"
BrandonC-4585 answered DatLam-8030 commented

I too am having the same issue. Exchange 2016.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

If mail queue is being backed up., check for event log D 3811 reffering to anti-mailware. If it appears, then run the following command to disable anti-mailware

Set-MalwareFilteringServer <ServerIdentity> -BypassFiltering $true. This worked for me.

more on commands disabling malware services on
https://docs.microsoft.com/en-us/exchange/disable-or-bypass-anti-malware-scanning-exchange-2013-help




1 Vote 1 ·
MarkusH-2270 avatar image
1 Vote"
MarkusH-2270 answered MarkusH-2270 published

Can't convert "2201010001" to ... long looks like a date + version number ... (20)22.01.01.0001 ... max-long is 2147483647 so it worked for (20)21.12.31.0000 but not for (20)22.01.01.0000. Fits the first log entries at 02:20 am today.

Exchange 2019 latest CU ... Disable-AntimalwareScanning.ps1 ... queus are "empty" now

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

LawrencePatterson-5520 avatar image
1 Vote"
LawrencePatterson-5520 answered

Hello, confirming that my Exchange 2016 CU22 is having a similar issue, started just after 8 PM EST, though my error is " The FIP-FS "Microsoft" Scan Engine failed to load. PID: 29572, Error Code: 0x80004005. Error Description: Can't convert "2201010002" to long. " which appears to be just slightly different from what I've seen.

Also see https://borncity.com/win/2022/01/01/exchange-fip-fs-scan-engine-failed-to-load-cant-convert-2201010001-to-long-1-1-2022/ with a further confirmation.

Can and will wait for a response from Microsoft, as we are in the middle of a downtime.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

MarkStott-0501 avatar image
1 Vote"
MarkStott-0501 answered CirrusSR22Joe-8847 commented

Update from Microsoft support - engineering team are aware of this issue and working on a fix at the moment.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

MarkStott, Any update from Microsoft?

0 Votes 0 ·
MaroianeGhdira-9447 avatar image
3 Votes"
MaroianeGhdira-9447 answered JV-8089 commented

Hello,
As a workaround you can just bypass malware filtering on all servers with a transport service restart afterwards (solution tested and validate)
--> Set-MalwareFilteringServer -Identity <SERVER NAME> -BypassFiltering $true
--> Restart-Service MSExchangeTransport

· 7
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I don't see anything on our queue for all mail servers and transport service is running. Emails seems to be going in and out. Should i just wait instead of applyinh your workaround? It seems the worst thing is the Filter Management service shut off. I was going nuts last night but check the FIPFS Engine and Data directory which suddenly recall from 2003 days that this has happened before.

0 Votes 0 ·

Following the feedback I have, the problem only concerns Exchange 2016/2019 servers, if you receive emails I do not recommend the workaround.

1 Vote 1 ·
JV-8089 avatar image JV-8089 MaroianeGhdira-9447 ·

Thanks for the reply. Yes we are on Exchange 2016 CU 20. Is there any other spot to check aside from the queue and transport service? What a New Year huh?

1 Vote 1 ·
Show more comments

perhaps you already have the antimalware agent disabled. use this command to verify

Get-TransportAgent "Malware Agent"

1 Vote 1 ·
JV-8089 avatar image JV-8089 TerenceSwales-7170 ·

You guys are right - it says False for Enabled.

0 Votes 0 ·
ADL123 avatar image
0 Votes"
ADL123 answered ADL123 published

this bypass worked for me! thanks so much. we were pulling our hair out trying to figure this out.

happy new year

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Samdi-4478 avatar image
0 Votes"
Samdi-4478 answered TerenceSwales-7170 commented

There are two methods to disable the malware scanning and fix the mail flow issues: See more: https://www.alitajran.com/exchange-mail-flow-breaks/

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

nice one Samdi-4478

0 Votes 0 ·
MPBSupport-9498 avatar image
0 Votes"
MPBSupport-9498 answered MPBSupport-9498 published

Setting malware bypass worked for me. Thanks

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

DenisGILLET-0140 avatar image
0 Votes"
DenisGILLET-0140 answered

By the way, no problem on Edge servers even with malware scanning enabled.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.