gMSA for SQL server service account for AlwaysON cluster, not restart automatically

zhiqing zhou 61 Reputation points

I have created two node SQL server cluster, each node has two SQL instance SQL2016 and SQL2019. AlwaysON created, no issues when using AD user account as SQL server service account. works great.
When I switch the SQL server service account to a gMSA account on SQL2016 and SQL2019, start the SQL service, AlwaysON works normal, no issues,
Problem was noticed after I reboot one node , and found that after reboot, the SQL server service with the gMSA service account doesn't start automatically, if I manually click to start it, it starts and works fine, the start type remains automatically.
I tested various senarios:

  1. change only SQL2016 or SQL2019 to gMSA, and the other instance to a AD user, the instance with regular AD user service account restarts after node reboot, only the instance using gMSA service account needs manually start it.
  2. tested using different AD users or same AD users on the instances, both restarts automatically after reboot the node, just gMSA not automatically restarts.

one Article mentioned failover clusters do not support gMSAs, but windows services can use gMSA, not sure it is related,
in another article, Microsoft mentions it supports gMSA for failover cluster availability group for sql2014 or later
found someone posted example for gMSA works for cluster, didn't mention any issues:

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
12,613 questions
0 comments No comments
{count} votes

Accepted answer
  1. Erland Sommarskog 100.8K Reputation points MVP

    Are there any error messages in Windows Event Log related to the attempt to start SQL Server?

    My prime guess would be that there is a delay in contacting the AD to validatte the gMSA. You could try to set SQL Server to start with Automatic (Delayed). (This option is only available in the Services applet.)

    1 person found this answer helpful.
    0 comments No comments

0 additional answers

Sort by: Most helpful