WSA, WSL, and Hyper-V virtual machines do not update via DHCP and break every reboot.

NekoBoiNick 1 Reputation point
2022-01-21T15:24:18.577+00:00

I have many months back had an issue just like this one, so I reinstalled windows. After which it happened again. The problem seems to be if I use vEthernet (WSL) and/or vEthernet (Default Switch) the virtual machines cannot connect to the internet. Nor can they ping the host computer.

I have tried many things. The network option on a Windows virtual machine seems to always say "Identifying..." but never goes anywhere. I can set the DNS to "8.8.8.8" and "8.8.4.4" but it doesn't make a difference, it cannot even ping the host computer. The host computer cannot even ping the virtual machine, which is still not good.

I have looked around the internet, some have said to use an external connection, but I have absolutely no clue how to set that for WSL and WSA. So just to say an external connection won't fix the underlying issue. Then some people have said to check the router if it's forbidding other DHCP servers from assigning IP addresses and that's not the case as VM ware works just fine, it seems to be with Hyper-V like stuff.

Does anyone know a fix for this? Did I somehow turn off a DHCP service that my computer should be running to assign the virtual networks' virtual machines an IP address or something?

System Center Virtual Machine Manager
Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,583 questions
{count} votes