Cannot RDP to Azure VM

Jevon Davis 141 Reputation points

I have come to realize tat I can no longer remote to my Azure VM. I could do so a day before but the following day I could not. I have tried all the necessary troubleshooting outlined in the RDP troubleshooting docs. I have tried:

  1. Resetting RDP configs
  2. Resetting RDP credentials
  3. Checking resource health
  4. Serial logs
  5. Resetting the NIC
  6. Redeploying the VM I had to restore from a backup which was a week old. I know the problem is with the VM but not sure how I could repair it. I tried to restore from the back up which occurred a day after it started giving issues and it is the same problem. Still cannot RDP so I think that tell me the problem is with the VM. Any solution I could try?

Update: The issue was resolved, detaching the disc and attempting a repair seems to have narrowed it down to a particular VPN software that had taken over the ports for connection. It was uninstalled, the disk reattached and connecting was once more possible

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
5,921 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
3,789 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Manu Philip 16,561 Reputation points MVP

    Without properly understanding the issue on the backup, we can't troubleshoot the issue well.
    Still, I am thinking an option.

    • Create a different VM within the same subnet with a similar internal IP range of the problematic VM
    • Try RDP from the new VM, using internal IP (Make sure that there is no NSG rules set to block the RDP port 3389)
    • If still RDP is not working, try accessing the the the VM's services, files etc. to see if something can indicate the problem

    If the Answer is helpful, please click "Accept Answer" and upvote it