Azure Virtual Machine Scale Set stuck in deleting mode

Wojciech Piechota 21 Reputation points

I have created Service Fabric Cluster on my azure subscription. I tried to delete it via Azure portal but VMMS stuck in deleting state for more than 2 hours. I tried to delete whole resource group but the process seems to stuck as well. What else can I do to delete the resource group ?

Azure Service Fabric
Azure Service Fabric
An Azure service that is used to develop microservices and orchestrate containers on Windows and Linux.
229 questions
Azure Virtual Machine Scale Sets
Azure Virtual Machine Scale Sets
Azure compute resources that are used to create and manage groups of heterogeneous load-balanced virtual machines.
301 questions
0 comments No comments
{count} votes

Accepted answer
  1. Pradeep Kommaraju 2,541 Reputation points

    Hi @Wojciech Piechota

    Thank you for reaching out to Microsoft Q&A forums .

    Regarding your issue of VMSS stuck in Deleting state , It might be either a Azure Backend issue which needs service engineering teams to patch them VMSS manually so that you can delete it without any issues , Or it might be a case where there are multiple dependent resources causing the same .

    You can review the Activity logs of the VMSS to see if the operation to delete the VMSS failed with any known issues {Dependencies } , If not please do create a support ticket to Support teams who can work can help you on the mitigation of this provisioning issue .



    Please don't forget to either "Accept the Answer" or "up-vote" if this response was informative and helpful .

0 additional answers

Sort by: Most helpful