Problems deploying feature updates

Tom 1 Reputation point
2020-08-21T10:15:06.767+00:00

Hi,

I'm running CB 2003 and trying to deploy the 2004 feature update but I keep coming up against this error in PatchDownloader.log

Failed to move \\sccm01\Repository\Packages\Updates\FeatureUpdate2004\1ba890bc-a7d6-4d44-a7a8-ed012f5881af.1 to \\sccm01\Repository\Packages\Updates\FeatureUpdate2004\1ba890bc-a7d6-4d44-a7a8-ed012f5881af, error 121 Software Updates Patch Downloader 21/08/2020 10:45:20 10724 (0x29E4)
Will retry in 10000ms Software Updates Patch Downloader 21/08/2020 10:45:20 10724 (0x29E4)
Failed to move \\sccm01\Repository\Packages\Updates\FeatureUpdate2004\1ba890bc-a7d6-4d44-a7a8-ed012f5881af.1 to \\sccm01\Repository\Packages\Updates\FeatureUpdate2004\1ba890bc-a7d6-4d44-a7a8-ed012f5881af, error 121 Software Updates Patch Downloader 21/08/2020 10:50:46 10724 (0x29E4)
Will retry in 10000ms Software Updates Patch Downloader 21/08/2020 10:50:46 10724 (0x29E4)
Failed to move \\sccm01\Repository\Packages\Updates\FeatureUpdate2004\1ba890bc-a7d6-4d44-a7a8-ed012f5881af.1 to \\sccm01\Repository\Packages\Updates\FeatureUpdate2004\1ba890bc-a7d6-4d44-a7a8-ed012f5881af, error 64 Software Updates Patch Downloader 21/08/2020 10:53:06 10724 (0x29E4)
Will retry in 10000ms Software Updates Patch Downloader 21/08/2020 10:53:06 10724 (0x29E4)
Failed to move \\sccm01\Repository\Packages\Updates\FeatureUpdate2004\1ba890bc-a7d6-4d44-a7a8-ed012f5881af.1 to \\sccm01\Repository\Packages\Updates\FeatureUpdate2004\1ba890bc-a7d6-4d44-a7a8-ed012f5881af, error 64 Software Updates Patch Downloader 21/08/2020 10:56:23 10724 (0x29E4)
MoveFile() failed to rename \\sccm01\Repository\Packages\Updates\FeatureUpdate2004\1ba890bc-a7d6-4d44-a7a8-ed012f5881af.1 to \\sccm01\Repository\Packages\Updates\FeatureUpdate2004\1ba890bc-a7d6-4d44-a7a8-ed012f5881af with GetLastError() = 64 Software Updates Patch Downloader 21/08/2020 10:56:23 10724 (0x29E4)
ERROR: DownloadUpdateContent() failed with hr=0x80004005 Software Updates Patch Downloader 21/08/2020 10:56:23 10724 (0x29E4)

The user running the console has full permissions on that folder, as does the site server computer account.

What am I missing?

Edit: If I manually rename 1ba890bc-a7d6-4d44-a7a8-ed012f5881af.1 to 1ba890bc-a7d6-4d44-a7a8-ed012f5881af whilst SCCM is trying to do it, it works. Feels like SCCM hasn't got enough permssions to the folder but it has?

Thanks

Microsoft System Center
Microsoft System Center
A suite of Microsoft systems management products that offer solutions for managing datacenter resources, private clouds, and client devices.
265 questions
No comments
{count} votes