SCOM-IIS 10 application endpoint is not being discovered

asked 2020-08-25T12:06:30.987+00:00
Alexey K 21 Reputation points

Hello,
I recently installed the Microsoft Windows Server 2016 and 1709+ Internet Information Services 10, Operations Manager APM Web IIS 10 MPs in order to monitor a .NET application.
The website on which the application is installed was discovered successfully, but the application endpoint is missing from the IIS 10.0 ASP.NET Web Application Inventory, as well as from the Discovered Inventory. Other applications from different IIS 10 servers have been discovered, but not the one I want to monitor.
I was not able to understand how the discovery process of application endpoints is carried out by SCOM from the MP documentation.
Please advise

Operations Manager
Operations Manager
A family of System Center products that provide infrastructure monitoring, help ensure the predictable performance and availability of vital applications, and offer comprehensive monitoring for datacenters and cloud, both private and public.
1,199 questions
No comments
{count} votes

Accepted answer
  1. answered 2020-08-25T12:29:40.367+00:00
    Stoyan Chalakov 8,731 Reputation points Microsoft MVP

    Hi Alexey,

    this seem to be the discovery:

    Microsoft.SystemCenter.Apm.Web.IIS10.Endpoints.Group.DiscoveryRule (Discovery)

    not quite sure though why it does not work for this particukar .NET app. Are there any errors in the event logs on the server, hosting it? Can you please check that.
    The other tzîng is that you need to wait at öeast 4 hours for the dioscvery to kick in. If this is the case and 4 hours have passed, please try to find some clues on the agent side in the Operations Manager event logs.

    Regards,
    Stoyan

    No comments

0 additional answers

Sort by: Most helpful