SSMS 18.11.1 Beeps When I Close a Query Window

JediSQL 76 Reputation points

I just upgraded SSMS, SQL Server Management Studio, from 18.9.2 to 18.11.1. Now every time I close a query window, I get the windows beep. How do I turn that off?

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
11,019 questions
{count} votes

Accepted answer
  1. Ronen Ariely 15,051 Reputation points

    Hi guys,

    I did some tests and in first glance this seems like a bug

    When SSMS editor windows is closed then it should first run the command to disconnect and seems like this part is missing. If you manually disconnect before you close the editor window then there will be not Beep sound


    Update: I published it here as well:


    14150-image.pngRonen Ariely
    Personal Site | Blog | Facebook | Linkedin

    3 people found this answer helpful.

8 additional answers

Sort by: Most helpful
  1. Erland Sommarskog 88,626 Reputation points

    There is a feature request to disable the sound for this issue: >
    sounds like it'll be addressed in the next release :)

    I'm taking the liberty to repost this in the Answers section, since this answers the issue. I was talking to a Microsoft contact, and they are indeed aware of the issue and they will address it.

    2 people found this answer helpful.
    0 comments No comments

  2. CathyJi-MSFT 20,986 Reputation points Microsoft Vendor

    Hi @JediSQL ,

    Please uncheck “Play the Windows default beep…” option in SSMS setting. SSMS-> Tools->Options->Query Results->SQL Server->General-> uncheck “Play the Windows default beep…” option. Restart SSMS.


    If it is not work, you could try to repair or even reinstall SSMS, but if it doesn't help, the fact that booting in Safe Mode fixes the problem might indicate that some third-party application is responsible for it. Quote from this similar thread.

    Or you can stop beep sound on windows as below screenshot. Control Panel\Hardware\sound. Refer to How to Disable System Beep Sound on Windows.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    1 person found this answer helpful.

  3. Eitan Blumin 16 Reputation points MVP

    I'm having the same problem right after upgrading to 18.11

    The option under Query Results > General is already off and I tried turning it on and off again and it didn't help.
    Repairing SSMS and even restarting didn't help either.

    I have Red-Gate SQL Prompt installed, but it has no such feature that activates sounds in SSMS. I had it installed long before upgrading SSMS to 18.11. (regardless, this problem was reported by people who don't have SQL Prompt installed as well)

    It is unreasonable to expect us to turn off sounds at the Windows level when it is clearly a problem with the new SSMS version.

    1 person found this answer helpful.

  4. Erland Sommarskog 88,626 Reputation points

    I have also noticed this, and the sound played is the Exclamation sounds. I can live with it, so I have not made a lot of fuzz about it. I guess it is some accident. I don't think there is a setting in SSMS to turn it off.

    I suggest that you file a bug on

    0 comments No comments