Chart on different sheet in Excel 365 is not updating automatically

Don Anderson 61 Reputation points
2022-03-25T22:18:43.033+00:00

I have a table of values for an investment account in Excel 365. I selected the column with the balance dates then held down the CTRL key and selected the balances in that column and clicked Insert and chose a line chart with data points. I also made the data array a table. The chart will automatically update if I add a new row of data to the table. However I moved the chart to its own tab/sheet using right-click > Move. Now the chart no longer updates when I add a new row of data to the table.

How can I fix this issue?

Thanks,
Don

Excel Management
Excel Management
Excel: A family of Microsoft spreadsheet software with tools for analyzing, charting, and communicating data.Management: The act or process of organizing, handling, directing or controlling something.
1,671 questions
0 comments No comments
{count} votes

Accepted answer
  1. Ceasar Chen_MSFT 4,391 Reputation points
    2022-03-28T09:46:49.827+00:00

    Hi, @Don Anderson
    Following your way, I made a data table and inserted a line chart, when I moved it to Sheet2, changed the data in the data table, the line chart will automatically update the data.
    I don't have a similar problem.
    187400-image.png
    187502-image.png187473-image.png

    You can check whether the table is Convert to Range in Design, the screenshot is as follows:
    187367-image.png
    Is your line chart moved to another Sheet under the original Excel file, or to a Sheet under the new Excel file?
    To help you better, please provide a specific case and attach a screenshot.

    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Don Anderson 61 Reputation points
    2022-03-28T17:57:32.437+00:00

    It appears to be working now. Not sure what was happening.
    Thanks,
    Don

    0 comments No comments