Application access policy not applied to my Graph API

Václav Uher 11 Reputation points

I would like to make an API call to create a new Online meeting in our company application that would create the meeting via Graph API. I created the app, added the permissions to OnlineMeetings.ReadWrite.All + User.Read and I granted the consent from the administrator.
After this I tried to create the meeting, but that failed with the error

No Application Access Policy found for this app.
After that i found the info about the Access policy setting and run those commands in powershell (after installing all needed modules)
New-CsApplicationAccessPolicy -Identity Teams-policy -AppIds "51c597d9-1969-4b5b-b5e3-xxxxxxxx" -Description "Permissions for Teams plugin"
then I granted the global permissions (app will be available for all users in company)
Grant-CsApplicationAccessPolicy -PolicyName Teams-policy -Global
and when I run Get-CsApplicationAccessPolicy I can see it created. But when I make the API call to create the meeting I still get the No Application Access Policy found for this app.
I even tried to call the New-CsApplicationAccessPolicy using the app ObjectId which ended up successfuly as well !? But no success with the API call either...
Could anyone give me a hint on what I possibly missed in the setup or what could be wrong ?

Microsoft Graph
Microsoft Graph
A Microsoft programmability model that exposes REST APIs and client libraries to access data on Microsoft 365 services.
9,174 questions
Not Monitored
Not Monitored
Tag not monitored by Microsoft.
32,862 questions
{count} vote

1 answer

Sort by: Most helpful
  1. CarlZhao-MSFT 32,126 Reputation points

    Hi @Václav Uher

    Obviously, you have correctly created the application access policy, but the tenant-based application access policy may have a long delay, you can try to call the api again after 30 minutes.

    User's image

    User's image

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    0 comments No comments