Facing error while loading data from oracle to Synapse.

Ganga Keerthi 1 Reputation point

Facing this error while loading the data from Oracle to Synapse Using ADF. Error[HY000] [Microsoft] [ODBC Oracle Drive Protocol Driver] [Oracle] Unexpected network error. Error[HY000] [Microsoft] [ODBC Oracle Drive Protocol Driver] [Oracle] ORA-12656 Cryptographic Checksum Mismatch. Tried different ways as adding WorkAround, EnableBulkLoad parameters to Oracle connection String but of not use. Could you please suggest.

Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
8,507 questions
{count} votes

3 answers

Sort by: Most helpful
  1. KranthiPakala-MSFT 45,902 Reputation points Microsoft Employee

    Hello @Ganga Keerthi ,

    Thanks for the question and using MS Q&A platform.

    As per my understanding, you are receiving the above error message while trying to copy data from Oracle to Synapse using ADF copy activity. Please correct I'm not accurate.

    While doing research on this error, I found the below article related to it. Could you please have a look at this and work with your database administrator concerning the data integrity settings of your Oracle server and see if that helps: Very intermittent copy activity fails with ORA-12656: Cryptographic checksum

    Here is the root cause and workaround discussed in the above article, could you please verify yours and see if that helps:


    Below are related helpful docs:

    If the issue still persists, I recommend filing a support ticket for deeper investigation. Do let us know how it goes.


    0 comments No comments

  2. Ganga Keerthi 1 Reputation point

    I have tried adding dataintegritylevel=0 in the connection string which solved the issue.

    Thank you for the suggestion. @KranthiPakala-MSFT

    Please close this thread from your end. WIll get back to you if anything required.

  3. 46473808 0 Reputation points

    For users facing this issue still with dataintegritylevel=0 set in ADF: We have encountered this issue intermittently when ADF is loading large datasets from ORACLE. We have found that the Oracle driver used by ADF has issues with the BINARY_DOUBLE datatype in Oracle. Possibly other datatypes as well that ADF recognizes as Decimal. The workaround we have used is casting these fields to character using Oracle function TO_CHAR(YourColumnName, 'TM') as YourColumnName on the initial queries which has fixed the issue.
    sense that that issue is with the driver having issues with the hash of those columns overloading the buffer or something along those lines

    0 comments No comments