I am unable to create compute instance

Mayank Sharma 26 Reputation points

​I am unable to create compute instance in my azure ml resource. I am using a free trial and already have 6 unused cores left in my quota. I have used central India as my location. While making the compute instance, It shows - "You do not have enough quota for the following VM sizes".

I've added a screenshot.

Please let me know what is the solution to this problem.

Azure Machine Learning
Azure Machine Learning
An Azure machine learning service for building and deploying models.
2,248 questions
{count} votes

7 answers

Sort by: Most helpful
  1. Connor McKenna 11 Reputation points

    I am having the same issue with the West US region

    2 people found this answer helpful.
    0 comments No comments

  2. vyago 6 Reputation points

    Having the same issue here, first i tried to set up the region in west germany then to eastus, nothing works since I am not able to set select any virtual machine with my free trial account

    I was following the DP-100 tutorial for deep-learning and it suggests the free trial account would be enough:


    • A Microsoft Azure subscription. If you don't already have one, you can sign up for a free trial at https://azure.microsoft.com/free.
    • An Azure Machine Learning workspace with a compute instance and the ml-basics repository cloned.

    Its seems to be misleading given the case

    Edit: Upgrading to pay-as-you-go does not solve the problem

    1 person found this answer helpful.
    0 comments No comments

  3. Samantha Movius 16 Reputation points

    You have to request an increase in Quota through Microsoft, it can take awhile but it will work. It does not make sense to me why the default would be 0 VM cores.

    1 person found this answer helpful.
    0 comments No comments

  4. Srinivas Krishnaswamy 21 Reputation points

    I was able to create a compute instance after I recreated the Azure ML workspace in AustraliaEast. But when i tried it 3 days later it is not allowing me to create one ( have to check quotas i think).

    But bottom line AustraliaEast seemed to work


    1 person found this answer helpful.
    0 comments No comments

  5. Mohamed Abdelrahman 6 Reputation points

    I have the same problem with eastus2 region, that it didn't allow me to select any virtual machines

    1 person found this answer helpful.