Network route not correct

Fellerson 1 Reputation point
2022-04-06T10:41:09.557+00:00

Hi dear,
i've a computer with 2 ethernet adapters.
X000 is connected on a "public" network with internet
190460-x001.png

X001 is connected on a "private" network without internet. i should reach other components over this adapter
190561-x000.png

When i try to reach an IP over X001 private network, for example, 10.31.124.133, it works perfectly, it uses the gateway from X001 (10.31.92.129). But when i try to reach an another IP, 10.31.124.134, it should be over the same X001 private adapter. But here, it tries to go over the gateway from the X000 adapter (10.194.84.162)

190419-tracert.png

Why ?!
thanks

Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
2,312 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 39,501 Reputation points
    2022-04-11T15:54:20.053+00:00

    Hi @Fellerson

    You must first check your Priority sequence of the Network Adapters in Windows.

    1. Press the Windows Key + X and select Network Connections from the menu.
    2. Press the ALT key, click Advanced, and then Advanced Settings.
    3. Select the network connection and check the priority of the network connection.

    Also if you configure a Windows-based computer that has more than one network adapter on the same physical network and protocol subnet, you may experience unexpected results.

    This article describes the expected behavior of this kind of nonstandard configuration.
    How multiple adapters on the same network are expected to behave https://support.microsoft.com/en-us/topic/how-multiple-adapters-on-the-same-network-are-expected-to-behave-e21cb201-2ae1-462a-1f47-1f2307a4d47a

    Hope this resolves your Query!!

    -----------

    --If the reply is helpful, please Upvote and Accept it as an answer–

    0 comments No comments