question

psaban20-9577 avatar image
2 Votes"
psaban20-9577 asked Kyle-0572 commented

Cannot turn off the AlwaysOn feature on Azure App Service

I'm trying to turn off the AlwaysOn feature for my App Service, but after saving the change it reverts back to "On".

Steps I'm taking are:

  1. From the App Service > Configuration > General Settings

  2. Toggle "Always On" from "On" to "Off"

  3. "Save" and "Continue"

I refresh and the AlwaysOn feature reverts to "On"

Any help is appreciated.

azure-webappsazure-webapps-scaling
· 8
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @psaban20-9577

Is this a Windows or Linux App Service Plan? Which Tiers is this?

Can you tell us what you are trying to achieve by disabling this?

Regards,
Didier3001

0 Votes 0 ·

It's a Windows Service Plan currently on a B1 pricing tier. I'd like to scale down to either D1 or F1 pricing tier but those require the AlwaysOn feature to be turned off. When I try to scale down to either of those pricing tiers I get a notification:

"Cannot update the site '[my sitename]' because it use AlwaysOn feature which is not allowed in the target compute mode"

So I then go to the apps Configuration > General Settings, turn off the AlwaysOn feature and save. When I refresh to check if the change saved the AlwaysOn feature is back to On.

0 Votes 0 ·

Hello there. I am experiencing the same issue, I am using a Windows Service Plan P1V2 and I want to scale back to the free tier, since initially I want to continue developing the application and would not like to be charged unnecessarily. AlwaysOn is always enabled back on whenever I go to Configuration > General Settings, disable it and hit refresh.

Please advise on what to do next.

0 Votes 0 ·

@MinhThnh-3947, @psaban20-9577,

Apologies for any inconvenience with this issue and for the delayed response! I understand this issue can be frustrating.

For a much closer look to identify the root cause and so we can provide immediate and specialized assistance, kindly send an email with subject line “Attn:Ajay” to AzCommunity[at]Microsoft[dot]com referencing this thread, Azure subscription ID, WebApps name, I will follow-up with you.

Having mentioned that, kindly try via CLI and see if that helps.

 az webapp config set --name mywebapp --resource-group myresourcegroup --always-on false

Is this your Java WebApp on Windows?

Kindly be assured that I have relayed this feedback to our engineering team.

You could also disable Always on via Resource explorer or PowerShell.
23874-image.png


Edited: Added/highlighted more info


1 Vote 1 ·
image.png (125.3 KiB)
Show more comments

0 Answers