SOLVED - Exchange 2010/2016 coexistence and protocolSettings AD Attribute error

Guillaume de Saint-Jores 21 Reputation points
2022-04-13T12:56:30.773+00:00

Hi everybody.

A strange thing happening to me for the first time during an Exchange 2010 migration to 2016 (they had Exchange 2003 some years ago, but not anymore).

My client has disabled OWA, ActiveSync, IMAP and POP for 95% of their users. For the remaining users, they can access everything (IMAP and POP are not used, but anyway... )

In the Exchange 2010 console, if I enable or disable OWA/IMAP/POP/Active Sync for a user, the Active Directory attribute "Protocol Settings" is updated (goes to 0 if disabled or 1 if enabled).

But, if I try to do the same in the Exchange 2016 console, the AD attribute is not updated, I have to update this with the AD console, with Powershell, or with the Exchange 2010 Console (which will be removed soon).

Does anyone has an idea how to correct this? How can I allow the Exchange 2016 console to update the setting or how can I do something to update the user's settings correctly?

Regards

Active Directory
Active Directory
A set of directory-based technologies included in Windows Server.
4,351 questions
Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
6,541 questions
0 comments No comments
{count} votes

Accepted answer
  1. KyleXu-MSFT 25,866 Reputation points
    2022-04-14T06:00:23.483+00:00

    @Guillaume de Saint-Jores

    Glad to see you find the correct one. If the above suggestion helps, please feel free to accept it as an answer to close this thread. It also could be beneficial to other community members reading this thread.

    I notice this one:

    I think I will have a great job to update every user account to the new parameter...

    You could use the command below to check whether one of them enabled for mailboxes:

    Get-Mailbox -RecipientTypeDetails UserMailbox -ResultSize Unlimited | Get-CASMailbox | where {$_.ActiveSyncEnabled -eq $True -or $_.OWAEnabled -eq $true -or $_.PopEnabled -eq $true -or $_.ImapEnabled -eq $true}  
    

    If you want to disable them for those mailboxes, you could use the command below to disable them (It will disable those 4 protocols for all mailboxes):

    Get-Mailbox -RecipientTypeDetails UserMailbox -ResultSize Unlimited | Get-CASMailbox | where {$_.ActiveSyncEnabled -eq $True -or $_.OWAEnabled -eq $true -or $_.PopEnabled -eq $true -or $_.ImapEnabled -eq $true} | Set-CASMailbox -ActiveSyncEnabled $false -OWAEnabled $false -PopEnabled $false -ImapEnabled $false  
    

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


    0 comments No comments

3 additional answers

Sort by: Most helpful
  1. Andy David - MVP 121.3K Reputation points MVP
    2022-04-13T13:18:45.253+00:00

    The 2016 console should work now. Check the CASMailbox settings

    get-casmailbox <user> |FL

    It should show what protocols are enabled or disabled

    0 comments No comments

  2. Guillaume de Saint-Jores 21 Reputation points
    2022-04-13T14:35:53.613+00:00

    Hi Andy

    Just checked your command, it works, but still not in the console, but I found why.

    If I make a change with the Exchange 2010 console, the "Get-CASMailbox" parameter changed (for OWA for example) is named "OWA Enabled" (true or false).
    If I make the same change with the Exchange 2016 console, this is not the same parameter which is modified. It modifies the "OWAforDevicesEnabled" parameter.

    So the 2 consoles changes a different parameter name...
    I think I will have a great job to update every user account to the new parameter...

    0 comments No comments

  3. Guillaume de Saint-Jores 21 Reputation points
    2022-04-13T15:39:21.637+00:00

    So please, forget everything, I didn't choose the good parameter...

    Sucha shame for me.

    Thanks for your help

    0 comments No comments