visual studio 2019 f1 help not working

Anthony Weathers 46 Reputation points Microsoft Employee
2022-04-14T23:05:22.067+00:00

When I use the F1 key with a function name highlighted, the web page indicates the request was blocked. The link the browser is trying to access is:

https://msdn.microsoft.com/query/dev16.query?appId=Dev16IDEF1&l=EN-US&k=k(CORECRT_WSTDLIB%2F_wtoi);k(_wtoi);k(DevLang-C%2B%2B);k(TargetOS-Windows)&rd=true

and the response is:

The request is blocked.
0YqdYYgAAAAAPocZB9/F3SrIt+RquG8VGU0pDRURHRTA1MDYANWNmZWQzYjYtMDM5Yi00NWZmLTg4ODMtNjQzZDBlYzQ5MTg2

I get the same type of response if I strip the URL down to https://msdn.microsoft.com/.

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,764 questions
{count} votes

Accepted answer
  1. bernard Hauzeur 91 Reputation points
    2022-04-19T10:32:54.367+00:00

    cookie cleanup was the cure in my context

    3 people found this answer helpful.

3 additional answers

Sort by: Most helpful
  1. Tianyu Sun-MSFT 28,661 Reputation points Microsoft Vendor
    2022-04-15T09:25:53.697+00:00

    Hi @Anthony Weathers ,

    Welcome to Microsoft Q&A forum.

    Which version of Visual Studio 2019 are you using? I notice that this issue was reported before and was fixed in Visual Studio 2019 version 16.6. If you are using a lower version of VS 2019, I suggest you try to update to use a higher version of VS 2019.

    If you are using a higher version of Visual Studio 2019, could you help to confirm whether this issue appears for other codes and other projects in VS 2019?

    Best Regards,
    Tianyu

    • If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
      Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

  2. Eric Beaudry 1 Reputation point
    2022-04-22T02:36:11.037+00:00

    same problem here too.

    Had that problem a week ago and removing cookies (or using an InPrivate session with the link) worked for a couple days. The issue studently returned moments ago and now even InPrivate is not working.

    Microsoft Visual Studio Professional 2022 (Pro) (64-bit) - Preview Version 17.2.0 Preview 3.0
    Edge Version 100.0.1185.44 (Official build) (64-bit)

    0 comments No comments

  3. Wilbert Verhoeven 1 Reputation point
    2022-04-22T07:30:19.737+00:00

    For me the same problem, clearing all cookies works for mee
    it has nothing to do with Visual Studio, it has to do with cookies / login info edge is sending clearing the cookies (all sites) helps

    I had this problem using ipv6.. Has it to do with country's blocking ?

    0 comments No comments