Id Field mapping not working between azure blob and index

teja_98666 36 Reputation points
2022-04-20T12:39:06.683+00:00

Hi,

I have file stored in Azure blob storage and each blob has a custom meta data property with name as Id.

194698-image.png

Now i created an index in Azure cognitive search and added a field with name as "Id" i.e. matching the meta-data property of the blob hoping that it automatically maps the property to the field in the index.

194677-image.png

When i ran the indexer it doesnt populate the value of the Id property of the blob but instead creates a different unique id.

194734-image.png

i tried using Filed mapping property on the indexer but it throws an error saying that Id property is not available in the Source but as show in the above screenshot the property is still available on the Source.

194718-image.png

How do i map the Id meta-data property on the blob to the Id field in the index. Can any of you help me with this issue?

Azure AI Search
Azure AI Search
An Azure search service with built-in artificial intelligence capabilities that enrich information to help identify and explore relevant content at scale.
845 questions
{count} votes