How to recover a Subscription on Azure

Ryan T 1 Reputation point
2022-04-20T19:01:56.07+00:00

Hi,

We had an issue where we were locked out of our Microsoft account for 3 weeks.

All of our users were deleted - every last one.

We contacted Microsoft - waited for the Data Protection team - we're finally back in our account.

They setup a totally new user - gave us the password - then talked us through setting up 2FA etc.

But now nothing works

I opened up Azure and it was as if I were a new customer.

We had a Kubernetes service, a dev ops, a SQL Database and tons of other stuff.

I can still access the SQL Database but I can't manage it through Azure.

Is there any way to get this back?

I've made multiple Azure support tickets - but every department sends me to another department.

I signed up for Azure P2 support and still no luck, I'm awaiting an email back from our resellers but Microsoft have been pretty awful throughout the whole ordeal.

Is anyone aware of a department that can help with an issue like this?

We have full access to the accounts / tenant now, but I can't see any of the previous subscriptions.

And when I try to open DevOps - it treats me like a new customer.

I'm also having issues with my Office365 apps, there stuck in some kind of login loop.

Any help would be appreciated.

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,561 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Martin Meiner Tästensen 456 Reputation points
    2022-04-20T19:49:39.04+00:00

    To be clear, you are still connected to your old tenant? If yes, then i would assume that you don't have access to the subscriptions anymore since the permissions on those are set using IAM on those specific subscriptions and ressources, and by your explanation it sounds like you got entirely new users.

    If i'm right, then you need a user with the Global Administrator role, when you have that, please navigate to "Azure Active Directory Services" --> Scroll down and find "properties" --> change the switch named "Access Management for Azure ressources" to yes.

    Now go get a cup of coffee, this can take a few minutes. Please go to subscriptions and see if you can see all your "missing" subscriptions now. If you can, you need to set permissions for the required users for each of them again.

    Please note: this changes your permissions to each management group and subscription to "user access administrator", so you are now allowed to set permissions on every level of subscription and management group

    194824-azure-access-permissions.jpg


  2. Ryan T 1 Reputation point
    2022-04-21T14:22:24.473+00:00

    I tried that with no luck, thank you for replying though.

    What did help for DevOps was to assign myself the DevOps Administrator role, I was then able to claim our DevOps back (Global Admins you'd think would have the same access).

    Azure support has just submitted a request for our old subscription to be transferred to my new admin account.

    Lots of hitting brick walls but I think we're almost sorted.

    0 comments No comments