Getting prompted to login again when clicking on the app

asked 2020-08-31T20:12:34.097+00:00
SenhorDolas 986 Reputation points

Hi
I setup RDS on a W2K19 server - one server Session Host and one server with all the other roles.
I can login fine internally but when using it externally I get prompted to login again when I launch the app.
I am fronting the web interface with Azure App Proxy.
Any ideas?

Azure Active Directory
Azure Active Directory
An Azure enterprise identity service that provides single sign-on and multi-factor authentication.
12,580 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
3,032 questions
No comments
{count} votes

Accepted answer
  1. answered 2020-09-01T02:18:19.777+00:00
    Jenny Yan-MSFT 9,196 Reputation points

    Hi,
    1.Kindly check if you have enabled "Bypass RD Gateway server for local address". It will omit the RD gateway when remoting form internal.
    21763-image.png

    2.Kindly check if you have enabled single sign-on between RD Web and RD Gateway with command shared in step 8.
    https://learn.microsoft.com/en-us/azure/active-directory/manage-apps/application-proxy-integrate-with-remote-desktop-services#direct-rds-traffic-to-application-proxy

    If everything configured well, the users are asked to authenticate once to Azure AD and once to RD Web, but they have single sign-on to RD Gateway.
    21833-image.png

    -----Please "Accept as answer" if the reply is helpful-----
    Thanks,
    Jenny


0 additional answers

Sort by: Most helpful