question

KrzysztofKurek-1746 avatar image
0 Votes"
KrzysztofKurek-1746 asked AnnuKumari-MSFT commented

Azure Synapse Analytics - stitch - short password

Hello,

I am having issue with connection between Stitch and Azure Synapse

Stitch:
196565-stitch.png


Azure Synapse:
196642-azure.png

password: #Af2r47K%v4,T
can you help me to solve this problem? I am trying for couple of days to handle that but each time I got the same error....

I connected to Azure Synapse Analytics via Stitch, but just after successful extraction of data, I got an error in load mode.
stitich user which I am trying to connect to Azure has got grant control parameter over my destination database.


azure-synapse-analytics
stitch.png (35.9 KiB)
azure.png (78.6 KiB)
azure.png (78.6 KiB)
· 6
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@KrzysztofKurek-1746 Can you please go through this link ? https://techcommunity.microsoft.com/t5/azure-synapse-analytics-blog/synapse-sql-password-so-secure-that-even-you-cannot-use/ba-p/2118544

As per the link, this issue has been observed in certain scenarios based on the client & protocol you use to connect to the database. There are multiple workarounds listed including checking for special characters in password : [] () , ; ? * ! @ =

0 Votes 0 ·

Thank you for your replay. Unfortunately that didn't help for my problem. I changed password into: EUwX9wIJqlYm4Np, got connection with Azure but still duting loading data I am getting same error as before: Password validation failed. The password does not meet policy requirements because it is too short.

0 Votes 0 ·

Hi @KrzysztofKurek-1746 ,
Thankyou for using Microsoft Q&A platform and posting your query.
As I understand your query, you are getting password validation error while trying to establish a connection between Azure synapse analytics and Stitch . Please let me know if my understanding is incorrect.

Could you please share more details on how are you generating the credentials. Are you using SAS URL to generate your credentials or creating login and password via SQL pool in synapse .

Could you please share any document which you are following or screenshot of your steps covered so far so that I can share the same with the internal team to escalate this issue? Here is one such blog post I found mentioning the steps for connecting Azure synapse analytics to Stitch:

https://www.stitchdata.com/docs/destinations/microsoft-azure-synapse-analytics/connecting-a-microsoft-azure-synapse-analytics-destination-to-stitch#generate-storage-credentials

Please let me know if it is aligned to what you are trying to do?

0 Votes 0 ·

@AnnuKumari-MSFT Thanks for replay.
Yes, your understating is correct.

I followed with this documentation: https://www.stitchdata.com/docs/destinations/microsoft-azure-synapse-analytics/connecting-a-microsoft-azure-synapse-analytics-destination-to-stitch
I made each step as it's described and used direct connection instead SSH tunnel.
I created "stitch" data base and "stitch" user was created via Microsoft SQL Server Management.

1 Vote 1 ·
AnnuKumari-MSFT avatar image AnnuKumari-MSFT KrzysztofKurek-1746 ·

Hi @KrzysztofKurek-1746 ,
I have raised the query with internal product team. I haven't yet heard back from them . Will be keeping you posted once I get response from their end. Thankyou for your patience!

1 Vote 1 ·
Show more comments

0 Answers