Right-clicking certian files like cmd.exe freezes explorer after windows 11 upgrade

gary hengeveld 41 Reputation points

If I right-Click on certain files explorer freezes and I have to use task manager to restart explorer.

  • I just upgraded to windows 11 pro from windows 10 pro on 4/24/22
  • I have tried disabling all context menu items through both msconfig and ShellExView
  • I have tried rebooting into safe mode (Does it in safe mode)
  • I have tried clearing file explorer cache
  • I have reregistered file explorer using powershell
  • I have delete BagMRU and Bags keys in the registry
  • I have disabled all startup programs and services

I really don't want to reinstall windows 11 if possible. I have a lot of important programs that will take me forever to re-setup and this is my business computer

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
4,777 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Michael Taylor 41,636 Reputation points

    Bringing up the context menu requires Windows to enumerate the registry for the file/shell types to build the menu options and run any shell extensions that have registered as context menu handlers. Most likely it is one of these registered handlers that is causing the still. AV is also going to get triggered because you're interacting with files and that could slow things down but only if your AV is broken.

    I would disable/remove all context menu handlers that are part of third party apps and see if the problem goes away. Then add them back one at a time until the problem replicates. Some common context menu handlers would include source control-integration, comparison tools like Winmerge, etc. Most are done via the registry so they don't have to run in the shell but some use a handler. You can use the registry to find the registered menu handlers.

  2. gary hengeveld 41 Reputation points

    The only way I was able to repair this issue was to do a complete windows 11 reset wiping out all of my files and starting new. Now everything seems to be working

    0 comments No comments