Azure AD - Adding Mobility (MDM + MAM)

Travis 1 Reputation point

I'm attempting to add Airwatch MDM from the Mobility (MDM+MAM) page of Azure AD. Each time I try to add this, I get an error, which states

"Failed to add application AirWatch by VMware"

When I click on the error, it seemingly provides no details of significance...the full error code is as such:


I've tried adding Airwatch MDM from a private browser tab as well with no luck.

I should also note - I can add other MDM applications, such as Scalefusion, without issue. The problem seems to be isolated to Airwatch.

Azure Active Directory
Azure Active Directory
An Azure enterprise identity service that provides single sign-on and multi-factor authentication.
14,701 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Givary-MSFT 14,796 Reputation points Microsoft Employee


    Thank you for reaching out to us. As I understand you are adding Airwatch by VMware from Mobility (MDM and MAM) blade.

    From the details provided in the question, i see it is failing at AADGraphException, did a quick repro in my lab and i tried to add the same application, was able to add it successfully, during this process noticed following permissions are needed on Microsoft Graph


    I wanted to check account you are using to perform this activity, what kind of permissions does it have for Microsoft Graph ?

    Is it possible for you to perform the same operation with different Global admin account ? Also you can login to graph explorer, enter the credentials and verify the permissions ( under Modify permissions tab ).

    If the issue still persists, let me know.