wxWidgets Hello World example code

Bryan Kelly 266 Reputation points

I am returning to VS 2017 within Windows 10 after and absence. The goal is to learn how to use wxWidgets with the below video tutorial:

I have the “Hello World” program loaded. Added an include into properties and was rewarded with the squiggles for the #includes being resolved, but there are numerous more errors.

At 6:35 in the video he opens a new window, mentioning Power Shell and saying ctl-tilda.
I suspect that must be ctl-shift-tilda because the tilda is the upper case character.

His actions are fast, his words indicate he is opening a power shell from within the VS IDE. I tried all the permutations of ctl-~ and ctl-shift-~ and cannot get the control shell to open. Tried it outside the VS IDE with no results.

I think he starts power shell from within the VS IDE to create a json file in the correct location.
He types in: code vcpkg.json
I suspect this created a file of that name.

Then he opens a new window and seems to be editing this blank json file.
I don’t know where he gets this window.

I suspect the knowledgeable user understand what is going on so to prevent a too long question, which it already is, I stop here and ask for some hints.

Edit: I used notepad to create the file shown with the contents shown. Opened Power shell and tried the command

vcpkg.exe search wxwidgets

The reward is that vcpkg.exe is not recognized. Searched the directory where wxwidgets was unzipped for vcpkg.exe and not found there. Obviously I am missing something. Mostly knowledge.

A high-level, general-purpose programming language, created as an extension of the C programming language, that has object-oriented, generic, and functional features in addition to facilities for low-level memory manipulation.
2,894 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Minxin Yu 4,751 Reputation points Microsoft Vendor

    Hi, @Bryan Kelly
    Ctrl+~ does not work with VS2017. The video uses VS2019. You can also try to use the latest VS2022. In addition, you need to install VCPKG.

    Best regards,

    Minxin Yu

    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments