question

EngelmannFlorian-5684 avatar image
0 Votes"
EngelmannFlorian-5684 asked EngelmannFlorian-5684 answered

Standby breaks teams devices access (audio and video) in Ubuntu

Standby interrupts teams' access to devices (audio and video) in Ubuntu. There is no single audio/video device listed in the settings after standby (see screenshot).

197293-screenshot-from-2022-04-28-10-41-50.png

Teams: 1.5.00.10453
Ubuntu: 22.04 (same as 20.04 before the upgrade)
Audio: description: Audio device
product: Starship/Matisse HD Audio Controller
vendor: Advanced Micro Devices, Inc. [AMD]

Webcam: Logitech HD Pro Webcam C920

So far the only solution for this problem is a reboot (!!!).

The following attempts to solve the problem were unsuccessful:

Restart Teams with clean settings:
sudo killall -9 teams
rm -rf ~/.config/Microsoft/Microsoft\ Teams/

Play with different audio settings (eg. profiles):
pavucontrol

Reinstall Teams:
sudo killall -9 teams
rm -rf ~/.config/Microsoft/Microsoft\ Teams/
sudo apt resintall teams

Audio and video (including webcam) work fine in ALL other applications even after a standby, only Teams has this problem.

Any ideas?


office-teams-linux-itpro
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

EngelmannFlorian-5684 avatar image
0 Votes"
EngelmannFlorian-5684 answered JimmyYang-MSFT commented

I guess I found the problem (high level) and the workaround.

I do use Chromium browser, and it looks like teams fails to "detect" my audio/video devices if the Chromium browser is running BEFORE teams was started or after my system is waking up from a standby. So if I kill/close the browser and restart teams the devices are detected as expected. Launching Chromium after teams is running works fine.

This is no real solution as I have to kill -9 (to be able to restore all tabs on restart) Chromium which I use heavily at work.

Could anybody from Microsoft please let the teams developers know about this finding? It should be easy to fix?

· 6
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @EngelmannFlorian-5684

Thanks for your sharing. To make sure if it is a known issue, does anyone else have the same question in your organization?

Meanwhile, have you tried to login Teams web client to see if it can be reproduced?

0 Votes 0 ·

Hi @JimmyYang-MSFT

thank you for your answer. Most people in my organization do use other operating systems, so afaik this problem exists only with my setup.

I am able to use Teams via web client using chromium or chrome browser without any issue. The only reason I would like to use the "fat" client is the possibility to define a "second ringer". This allows me to use my monitor as a second ringer and I don't miss calls because I don't wear my headphones.

All the best,
Florian

0 Votes 0 ·
JimmyYang-MSFT avatar image JimmyYang-MSFT EngelmannFlorian-5684 ·

@EngelmannFlorian-5684

Thanks for your feedback!

So do you mean you are using Teams web client and desktop client at the same time, right? And when you are only using Teams for Linux client, it could detect the device normally?

0 Votes 0 ·

looks like this was just correlation. Today after waking up from stand by teams again lost all audio/video devices and killing chromium and restarting teams did not solve the issue.

0 Votes 0 ·
JimmyYang-MSFT avatar image JimmyYang-MSFT EngelmannFlorian-5684 ·

@EngelmannFlorian-5684

Have you tried to change another a/v device to see if it could be detected?

0 Votes 0 ·

@EngelmannFlorian-5684

Is there any update on this case?
Please feel free to drop us a note if there is any update.
Have a nice day!

0 Votes 0 ·
EngelmannFlorian-5684 avatar image
0 Votes"
EngelmannFlorian-5684 answered

No Update. Changing my devices (eg unplugging my webcam and replugging it) does not change anything within Teams fat client.

I am working with the webclient now. It looks like many other Linux users have the same issue.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.