set-mailboxregionalconfiguration unauthorized via certificate based auth

John Meyers 11 Reputation points
2022-04-28T13:32:25.75+00:00

It appears that the ability to call the 'set-mailboxregionalconfiguration' cmdlet when using certificate based authentication with exchangeOnline v2 module stopped working sometime in the last couple of weeks (early/mid-April). Prior to that it was working just fine in our provisioning scripts. If I authenticate manually with a global admin account to exchangeOnline, the cmdlet works fine. Just wondering if anyone else has run into this and if there's a work-around? Have tried adding more rights on the app registration side of things to no avail. I know there's some other cmdlets that are also broken (rights-wise) via certificate based auth.

Thanks.

Microsoft Exchange Online Management
Microsoft Exchange Online Management
Microsoft Exchange Online: A Microsoft email and calendaring hosted service.Management: The act or process of organizing, handling, directing or controlling something.
4,358 questions
Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,482 questions
Windows Server PowerShell
Windows Server PowerShell
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.PowerShell: A family of Microsoft task automation and configuration management frameworks consisting of a command-line shell and associated scripting language.
5,448 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Limitless Technology 39,506 Reputation points
    2022-05-04T07:35:33.97+00:00

    Hello JohnMeyers,

    This may be related with recent releases of the EXO v2 Module

    To report bugs please check: https://learn.microsoft.com/en-us/powershell/exchange/exchange-online-powershell-v2?view=exchange-ps#report-bugs-and-issues-for-the-exo-v2-module

    But first I would recommend to update the module as per instructions in the official article:

    https://learn.microsoft.com/en-us/powershell/exchange/exchange-online-powershell-v2?view=exchange-ps#update-the-exo-v2-module

    ------------------------------------------------------------------------------------------------------------------------------

    --If the reply is helpful, please Upvote and Accept as answer--


  2. John Meyers 11 Reputation points
    2022-05-04T14:57:31.86+00:00

    Ok, so some additional testing this morning and I come to find out it's actually working this morning without error. Was trying out a newer preview release on a fresh install and it was working, so rolled back to the non-preview release and it's also working. Just tried it on my production host and it's working there also, so Microsoft must have fixed something related to this. At least it only took them a little over a week to get it sorted out. Will post a follow-up if it starts failing again.