InTune Android system default apps not being installed on non-samsung devices

Michiel van Heerde 21 Reputation points
2022-04-29T11:14:35.3+00:00

Hi,

I am running into an issue with InTune and non-Samsung Android devices. We are running Android devices in Personally Owned Work Profile mode, this results in a separate Work profile on the Android devices. In that work profile the Samsung devices show some system default apps (but not all) and the non-Samsung devices do not show those system default apps. To get all Android devices to show the most used system default apps I created Android Enterprise System Apps for Camera, Contacts, Gallery, My Files and Phone. All apps are pushing out ok to Samsung devices but all non-Samsung devices are throwing an error code back and will not install the app, the error code: 0xC7D14FB5.

The package names for the apps are the default names that I found on internet, for example: https://www.petervanderwoude.nl/post/enhancing-the-work-profile-experience-with-system-apps/

I found nothing very useful on the error code besides the general Microsoft documentation: https://learn.microsoft.com/en-us/troubleshoot/mem/intune/app-install-error-codes

I am unable to find any info on non-Samsung devices having other package names for the system default apps.

Has anybody run into this issue and was able to solve it, or does anybody know if there is documentation on this situation that I have not found yet?

Kind regards,
Michiel

Microsoft Intune Application management
Microsoft Intune Application management
Microsoft Intune: A Microsoft cloud-based management solution that offers mobile device management, mobile application management, and PC management capabilities.Application management: The process of creating, configuring, managing, and monitoring applications.
910 questions
Microsoft Intune
Microsoft Intune
A Microsoft cloud-based management solution that offers mobile device management, mobile application management, and PC management capabilities.
4,692 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Jarvis Sun-MSFT 10,181 Reputation points Microsoft Vendor
    2022-05-02T08:49:32.247+00:00

    @Michiel van Heerde Thanks for your posting in our Q&A forum.

    Just to confirm whether it is an isolated phenomenon, need to clarify. Does this issue only occur in Personally owned work profile mode? Have you tried Android Enterprise dedicated devices or fully managed devices.
    I haven't encountered such a problem and there is no workload to reproduce your scenario. In order to better targeting the specific error code, it is recommended that you create an online support ticket to handle this issue. It is free. Here is the online support link:
    https://learn.microsoft.com/en-us/mem/intune/fundamentals/get-support


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    https://learn.microsoft.com/en-us/answers/support/email-notifications

    0 comments No comments

  2. Michiel van Heerde 21 Reputation points
    2022-05-02T10:25:22.527+00:00

    @Jarvis Sun-MSFT thanks for your reply.

    The issue shows in Personally Owned Work Profile mode yes.
    We have no dedicated devices, all devices are personally owned devices with a work profile.

    I have tried to create a ticket but since we are non profit we need to go through our LAR and those guys are not really responding as of yet so I wanted to see if more people encountered this issue though this way.

    Kind regards,
    Michiel

    0 comments No comments

  3. Michiel van Heerde 21 Reputation points
    2022-05-30T08:26:14.98+00:00

    This isse has been solved. All vendors are using their own package names for the Android System Default Apps it seems. You can find all correct package names in the Googe Play Store or by using something like the Package Names Viewer on an Android device to look them up.

    0 comments No comments