How to include a 200 Mb media file in my Azure-hosted website

Anna Naden 1 Reputation point
2022-04-30T02:30:05.923+00:00

I am a new user with Azure and Visual Studio. I have a web forms app that mostly works, except when I try to publish an mp4 media object using the video tag. Despite trying all possible settings, after publishing, browsing to that page returns a 404 error on the media file. Its size is 200 Mb. Am I running up against a resource limit? I am on the pay=as=you-go plan.

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
7,362 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Takahito Iwasa 4,841 Reputation points MVP
    2022-04-30T22:26:31.157+00:00

    Hi, @Anna Naden

    You try setting a MINE map for the mp4 file in web.config.
    The implementation is introduced in the following MSDN forum thread.

    https://social.msdn.microsoft.com/Forums/en-US/0ef40a56-1799-4f6d-8795-e72d92692a78/problem-to-put-video-on-azure-website-quotthe-resource-you-are- looking-for-has-been-removed-had?forum=AzureAPIApps

    0 comments No comments

  2. ajkuma 24,736 Reputation points Microsoft Employee
    2022-05-04T03:39:16.003+00:00

    To benefit the community. I'm just posting your answer from the other thread.
    -- @Anna Naden Thanks for sharing the solution that worked for you with the community. It's much appreciated.

    As you mentioned ," It turned out that my web pipeline didn't have mp4 enabled. To enable it, I had to add the following code to my web.config:"

    <system.webServer>  
    <staticContent>  
    <mimeMap fileExtension="mp4" mimeType="video/mp4" />  
    </staticContent>  
    </system.webServer>  
    

    If you have any further questions, please just let us know we will be more than happy to help.

    To benefit the community find the right answers, please do mark the post which was helpful by clicking on Accept Answer’ & ‘Up-Vote’.

    0 comments No comments