Root cause of External mailflow issue

SJ109 66 Reputation points
2022-05-05T13:10:27.783+00:00

We have exchange 2010 Hybrid set up with centralized mailflow enabled . We had an issue where emails to external was pending in the queue .
And also when I tried to access Powershell or any connectors in the server , received an error "Connecting to remote server failed. The ws-management service cannot process the request. The user load data of 67382482 requests per 60 seconds has been exceeded..........".

This was fixed after IISREST and recycle of "MSExchangePowershellAppPool".

In the mail queue, we could see that connection to O365 was showing retry.

And the mailflow issue was resolved after restarting Transport service.

I am trying to find the root cause here. Not seeing any relevant event logs. Please suggest what should be checked.

Thanks

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,494 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Andy David - MVP 145.1K Reputation points MVP
    2022-05-05T14:53:12.633+00:00

    Look at the at SMTP protocol logs for the send connector if enabled.
    Otherwise, enable them now for the next time it happens

    https://learn.microsoft.com/en-us/exchange/mail-flow/connectors/configure-protocol-logging?view=exchserver-2019

    0 comments No comments

  2. KyleXu-MSFT 26,241 Reputation points
    2022-05-06T09:32:08.173+00:00

    @SJ109

    And the mailflow issue was resolved after restarting Transport service.

    Based on your description, this issue was solved by restarting service. I think this issue isn't caused by configuration. It may be caused by network or computer performance.

    You could take the steps below to check it:

    Try to bypass smart host, observe for a while. If this issue doesn't occur, this issue may relate to the network with your Exchange and smart host.

    If this issue still occurs after bypassing smart host, have a check about Task Manager when this issue occurs. Check whether the server is under heavy load.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


    0 comments No comments