After upgrading to Exchange 2019 CU 12 Error 4999

HSvane 21 Reputation points
2022-05-06T13:49:29.69+00:00

Hi
I have a running system with a DAG with 3 DB all now running CU12 upgraded from CU 11. After upgrade all 3 DB servers have Error 4999.
The plan was to take one server and uninstall Exchange and the create a new server based on Windows 2022 and the install Exchange 2019 CU12.
But I can not uninstall Exchange 2019 CU12. The uninstall program stops with Error 4999.

  1. the uninstall when I started it from Apps and Programs stops with the error I don not have premission to run uninstall. Then I went to v15/bin and run the the uninstall as a administrator same error.
  2. the I added fuld access on the exchange program folder for "domain admin". Now the program started but ended with error 4999

So at this point I cannot uninstall the Exchange 2019 CU12 and on the other 2 DB exchange servers I am also getting Error 4999

Any suggestion to get Error 4999 to go away, and make it possible to uninstall CU 12

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,480 questions
{count} votes

Accepted answer
  1. Aholic Liang-MSFT 13,826 Reputation points Microsoft Vendor
    2022-05-09T09:01:13.413+00:00

    Hi @HSvane ,

    According to the Exchange 2019 CU12 KB: Cumulative Update 12 for Exchange Server 2019 (KB5011156) (microsoft.com)
    There is a known issue about Event ID 4999.
    200262-2022-05-09-01.png

    Please refer to this link and have a check if the symptoms are the same in your environment.
    If yes, please refer to the Workaround part in the link to resolve this issue.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our [documentation][4] to enable e-mail notifications if you want to receive the related email notification for this thread.

    [4]: https://learn.microsoft.com/en-us/answers/articles/67444/email-notifications.html

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. HSvane 21 Reputation points
    2022-05-09T17:29:00.483+00:00

    Hi
    Thanks for the answer. I have a test certificate which I am using to test the installation and it is for 1 month, so that fits.
    I have now tried to uninstall from command prompt with this command
    Setup.exe /mode:Uninstall /IAcceptExchangeServerLicenseTerms_DiagnosticDataOFF
    Where the command was run as administrator.
    This worked.
    Thanks for you help