question

StephanieLaurent-0278 avatar image
0 Votes"
StephanieLaurent-0278 asked SrinivasaRaoDarna-MSFT commented

Change to https://graph.microsoft.com/v1.0/shares/{encodedUrl}/driveItem

Good day @SrinivasaRaoDarnaMSFT-7657

We have seen a change in the https://graph.microsoft.com/v1.0/shares/{encodedUrl}/driveItem endpoint that happened around April 28/29th. We were not able to retrieve information on a document library and do not see any information on such a change in the changelog. Can you confirm what happened there? Please see log of a successful call and quickly thereafter a call that failed. Calls kept on failing from then on. We had to make an emergency change to our logic.


199802-image.png

Thanks
Stephanie


microsoft-graph-change-notifications
image.png (62.3 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

SrinivasaRaoDarna-MSFT avatar image
0 Votes"
SrinivasaRaoDarna-MSFT answered SrinivasaRaoDarna-MSFT commented

Hi @StephanieLaurent-0278,

Based on my test, shares-get-driveItem API working fine in my lab test. Don't have visibility to what changes have been made on this API on certain date.

Here is my test for the GET /shares/{shareIdOrUrl}/driveItem.

200675-839792-0.jpg

Also, from the attached screenshots you are using 2 different API's not the same endpoint.

200682-839792-1.jpg

References: shareddriveitem

Hope this helps,

If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have further questions about this answer, please click "Comment".


839792-0.jpg (109.8 KiB)
839792-1.jpg (81.3 KiB)
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @SrinivasaRaoDarnaMSFT-7657 ,

Apologies, I did not send the correctly filtered data. Please see screenshot below. Also note, that we now observed that the calls that were previously failing in late April/Early may are now successful. Could you please tell us what happened in the time period where they were failing?


201059-image.png


0 Votes 0 ·
image.png (35.8 KiB)

Hi @StephanieLaurent-0278,

Thanks for comment and confirming GET /shares/{shareIdOrUrl}/driveItem returned 200 in first instance and failed subsequent calls.

As the case needs additional troubleshooting and observe the logs(request-id & timestamps).
I would advise you to raise a support case with Microsoft Graph from the tenant where the issue is happening, a specialized Support Engineer will be able to assist you better.

You can raise technical support request from https://aad.portal.azure.com/#blade/Microsoft_Azure_Support/HelpAndSupportBlade/overview or https://admin.microsoft.com/#/support/requests.

Currently, I don't have visibility to what changes have been made on this API on certain date.
Hope this helps,

If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have further questions about this answer, please click "Comment".

0 Votes 0 ·