SCCM 2111 Prerequisites Check passed with warning .net 4.8

Sarfraz Aslam 166 Reputation points
2022-05-08T03:08:49.923+00:00

Hi,
I am stuck at Prerequisites check passed with warning at .net 4.8. I have site server on server 2016. I have installed .net 4.8 manually from the site https://www.prajwaldesai.com/fix-sccm-dot-net-prerequisite-check-warning/. After installation i have rebooted the site server. I have checked at SQL through query and in the registry. .net release is 528049. But still i am getting Prerequisites warning.
I have started the service SMS_WINNT_SERVER_DISCOVERY_AGENT, it stopped automatically after some time. There is no any error in ntsvrdis.log but also didn't find this "Look for the line “Detected .NET with the release 528449 on SCCM SERVER“. If you see the correct release version, you should not see the SCCM Dot NET 4.8 Prerequisite warning anymore."
Please support.
Regards,

Microsoft Configuration Manager Updates
Microsoft Configuration Manager Updates
Microsoft Configuration Manager: An integrated solution for for managing large groups of personal computers and servers.Updates: Broadly released fixes addressing specific issue(s) or related bug(s). Updates may also include new or modified features (i.e. changing default behavior).
1,008 questions
Microsoft Configuration Manager
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Rita Hu -MSFT 9,626 Reputation points
    2022-05-09T03:04:11.607+00:00

    @Sarfraz Aslam

    I am stuck at Prerequisites check passed with warning at .net 4.8. I have site server on server 2016. I have installed .net 4.8 manually from the site https://www.prajwaldesai.com/fix-sccm-dot-net-prerequisite-check-warning/. After installation i have rebooted the site server. I have checked at SQL through query and in the registry. .net release is 528049. But still i am getting Prerequisites warning.

    As far as I know, the .Net Framework 4.8 installed on Windows Server 2016 is release is 528049 but the Widnows Server 2022 is 528449.
    Reference picture:
    200082-10.png

    Related link:
    https://learn.microsoft.com/en-us/dotnet/framework/migration-guide/versions-and-dependencies#net-framework-48

    It seems that it is a normal behaviour. Note that it’s only a warning and will not halt your SCCM update installation.

    Reference screenshot in my lab for you:
    200091-11.png

    Best regards,
    Rita


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Rita Hu -MSFT 9,626 Reputation points
    2022-05-09T06:03:11.427+00:00

    @Sarfraz Aslam
    Thanks for your response.

    Is there any other warning? Please try to run the prereqchk.exe on the Server and resolve all items in the list that have an Error status. Also we could review the ConfigMgrPrereq.log to get more information.

    Reference screenshoot:
    200057-13.png

    Here is a link for you:
    https://learn.microsoft.com/en-us/mem/configmgr/core/servers/deploy/install/prerequisite-checker#run-with-default-checks

    Best regards,
    Rita


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.