question

MJacksonGMI-0400 avatar image
0 Votes"
MJacksonGMI-0400 asked ryanchill commented

Can not deploy to Azure app service

I have been trying for over a week to get code deployed to a deployment slot on Azure. The code is a modified version of the current site. The site works perfectly on my local machine. There is something not right with the deployment slot process. This morning I was able to deploy the code to a deployment slot and view the site. I then attempted to do a swap between deployment and production. The swap failed and now I can't view my site from deployment. I am getting a HTTP Error 503. The service is unavailable.


This afternoon when I tried again, I'm getting: You do not have permission to view this directory or page.

There I have open a case with Microsoft and the tech they are still working on it (It's been since April 28th - It is now May 10th).

I've tried building the deployment slot in Azure, in visual studio code, nothing works. I've also tried deploying with FTP - same results.

Has anyone actually deployed to a deployment slot on Azure? If so, what's the trick?



azure-webappsazure-webapps-content-deployment
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi, @MJacksonGMI-0400

I understand that I had a problem when doing a Swap from deployment to production.
If you swap from production to deployment again, will the website display correctly in the deployment slot?

In the Swap settings, you can select whether to swap database connection information etc. in the application settings. I suspect there may be a problem there.

0 Votes 0 ·

0 Answers