question

MiracleEbuka-2775 avatar image
0 Votes"
MiracleEbuka-2775 asked MiracleEbuka-2775 commented

Authenticate user in xamarin using AD B2C

I tried this sample
https://t.co/E1wfsbGcHa
However, after login it goes back to the login page instead of the login result page where the user info is displayed. After a day or so it then works as expected. This happens when the app is used for the first time. What could be the course and how do I fix it. Thanks

azure-ad-b2cazure-ad-msal
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @MiracleEbuka-2775,

I understand that you are trying to authenticate a user in Xamarin using B2C, but the user is getting redirected to the LoginPage.

I'm not sure if you are facing the same issue, but I gave seen some a similar cases where users were getting redirected to the b2c login page because the admin needed to reduce the minimum target Android and iOS versions.

200761-image.png

MSAL has a minimum OS version to target in Xamarin Forms builds.

Let me know if this helps or if you still face the same issue after trying this update.



If this answer helps resolve your question, please remember to "mark as answer" so that others in the community with similar questions can more easily find a solution.


0 Votes 0 ·
image.png (29.8 KiB)

The thing is that it doesn't get stuck in the b2c sign in page. The issue is that when user sign in, it navigate back to the xamarin page with the login button as if it wasn't successful, it doesn't navigate to the xamarin page where the user info is displayed after user is signed in. Now after several tries for some hours, it then navigate to the page where user info is displayed. This happens whenever I deploy the app to my android device. Please let me know If I'm not clear enough I can send a screenshot or screen record. Thanks

0 Votes 0 ·

The thing is that it doesn't get stuck in the b2c sign in page. The issue is that when user sign in, it navigate back to the xamarin page with the login button as if it wasn't successful, it doesn't navigate to the xamarin page where the user info is displayed after user is signed in. Now after several tries for some hours, it then navigate to the page where user info is displayed. This happens whenever I deploy the app to my android device. Please let me know If I'm not clear enough I can send a screenshot or screen record. Thanks

0 Votes 0 ·

0 Answers