question

RenePaquin-3677 avatar image
0 Votes"
RenePaquin-3677 asked RenePaquin-3677 published

scom 2022 reporting services configuration issue

Currently upgrading my test scom environment from 2019 to 2022 and having issues with installing SCOm reporting services. I did install srss 2019 on the same sql 2019 server as the OperationsManager and DW databases. I have an account that si my data reader account but it is not recognized. I have gone through the various permissions and I feel that I have covered them all. What could I be missing?

200999-scom-issue.png

Thanks,
Rene


msc-operations-manager
scom-issue.png (79.2 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

StoyanChalakov avatar image
1 Vote"
StoyanChalakov answered

Hi Rene,

do you use Group Managed Service Accounts or standard service accounts?
Can you please paste the relevant chunk of information from the Setup Log?

The path is: %LocalAppData%\SCOM\Log or by default c:\users\<UserName>\Appdata\Local\SCOM\Logs where <UserName> is the name of the user, who does the installation

Please scroll to the latest log entries and paaste whatever errors or exceptions you find there. We should be able to find a clue there.

Can you please also scroll quickly over the links, proovided in the following thread, maybe you wiil find something that you have missed:

Reporting Install fails - Data Reader account is not the same as in management group
https://social.technet.microsoft.com/Forums/en-US/f878f756-b483-489d-aa30-8999cb5e10cd/reporting-install-fails-data-reader-account-is-not-the-same-as-in-management-group?forum=operationsmanagerdeployment

Thanks in advance!


(If the reply was helpful please don't forget to upvote or accept as answer, thank you)
Regards,
Stoyan


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

SimonRenMSFT-3639 avatar image
0 Votes"
SimonRenMSFT-3639 answered

Hi,

Thanks for posting in Microsoft MECM Q&A forum.

1,May we know what version of SQL you are using? Operations Manager 2022 supports SQL 2019 with CU8 or later. Refer to the official article:
SQL Server Design Considerations

2,Similar threads for your reference:
SCOM 2012 Reporting installation issue
Deploying Reporting in the Multiple Server, Single MG - Stuck in Account Verification for Data Reader Account

Hope it helps. Thanks for your time.

Best regards,
Simon


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

RenePaquin-3677 avatar image
0 Votes"
RenePaquin-3677 answered RenePaquin-3677 published

Thanks for the responses. I am using SQL2019 with the latest CU. Here is the last little bit of the log. It appears that it cannot find he management server. This enry baffles me as I am entering in the fqdn of the management server.

[09:39:51]: Info: :Could not connect to Management Server: DEVSCOM01.local with exception: Threw Exception.Type: System.ApplicationException, Exception Error Code: 0x80131600, Exception.Message: We found 0 servers but expected only 1. This is a fatal error.


[09:39:17]: Error: :No Management Server property was provided and Setup could not find a valid Management Server. Please rerun setup with a valid management server.

[09:39:17]: Error: :The management server specified would lead to an invalid scenario. Setup will attempt to find a valid scenario mgt server.

[09:39:17]: Info: :Server Installed:False InstallingNow:False

[09:39:17]: Error: :No Management Server property was provided and Setup could not find a valid Management Server. Please rerun setup with a valid management server.

[09:39:17]: Always: :Entering Page: InstallationLocationPage

[09:39:33]: Info: :Info:User specified valid installation path of: H:\OperationsManager

[09:39:33]: Always: :Entering Page: PrerequisitesProgressPage

[09:39:33]: Debug: :LoadPrerequisites: Start adding ComponentTitles

[09:39:33]: Always: :LoadPrerequisites: Start adding DataItems

[09:39:33]: Always: :memoryCheckTitle

[09:39:33]: Always: :memoryCheckTitle

[09:39:33]: Always: :ntfsCheckTitle

[09:39:33]: Always: :DriveSpaceCheckTitle

[09:39:33]: Always: :DriveSpaceCheckTitle

[09:39:33]: Always: :OSVersionCheckTitle

[09:39:33]: Always: :OSVersionCheckTitle

[09:39:33]: Always: :PowershellCheckTitle

[09:39:33]: Always: :DomainControllerCheckTitle

[09:39:33]: Always: :WindowsInstallerCheckTitle

[09:39:33]: Always: :PendingRebootCheckTitle

[09:39:33]: Always: :WinRMCheckTitle

[09:39:33]: Always: :RemoteRegistryCheckTitle

[09:39:33]: Always: :ClusteredServerCheckTitle

[09:39:33]: Always: :ActiveDirectoryCheckTitle

[09:39:33]: Always: :IsComputerNameValidTitle

[09:39:33]: Always: :SEViewerInstalledCheck

[09:39:33]: Always: :AVIcodeAgentCheck

[09:39:33]: Always: :MOMASPAgentInstalledCheck

[09:39:33]: Always: :IISCheckTitle

[09:39:33]: Always: :IISMetabaseCheckTitle

[09:39:33]: Always: :AspNetCheckTitle

[09:39:33]: Always: :WindowsAuthRoleCheckTitle

[09:39:33]: Always: :StaticContentRoleCheckTitle

[09:39:33]: Always: :DefaultDocumentRoleCheckTitle

[09:39:33]: Always: :DirectoryBrowsingRoleCheckTitle

[09:39:33]: Always: :HttpErrorsRoleCheckTitle

[09:39:33]: Always: :HttpLoggingRoleCheckTitle

[09:39:33]: Always: :RequestMonitorRoleCheckTitle

[09:39:33]: Always: :RequestFilterRoleCheckTitle

[09:39:33]: Always: :StaticContentCheckTitle

[09:39:33]: Always: :IsapiAllowedCheckTitle

[09:39:33]: Always: :IsAspNetIntegratedHandlerInstalledTitle

[09:39:33]: Always: :HttpActivationCheckTitle

[09:39:33]: Always: :HttpActivationCheckTitle

[09:39:33]: Always: :LoadPrerequisites: Done adding prerequisites checks

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :<![CDATA[CheckPrerequisites: Logic Type:and DriveSpaceCheck-Fail: 0]]>

[09:39:33]: Debug: :

[09:39:33]: Debug: :CheckPrerequisites: DriveSpaceCheckTitle: Passed

[09:39:33]: Debug: :

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :<![CDATA[CheckPrerequisites: ProductType was not a match. Looking for: LanmanNT Found: ServerNTCheckPrerequisites: Logic Type:or OSVersion-w2k8R2-Fail: 2CheckPrerequisites: Logic Type:or OSVersion-w2k8R2-Fail: 0CheckPrerequisites: Logic Type:and ArchitectureIs64Check-Fail: 0]]>

[09:39:33]: Debug: :

[09:39:33]: Debug: :CheckPrerequisites: OSVersionCheckTitle: Passed

[09:39:33]: Debug: :

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :<![CDATA[IsComputerNameValid: Hostname: DEVSCOMSQL01 Len: 12CheckPrerequisites: Logic Type:and IsComputerNameValid: 0]]>

[09:39:33]: Info: :Approximated Memory = 12288

[09:39:33]: Info: :Approximated Memory = 12288

[09:39:33]: Debug: :

[09:39:33]: Debug: :CheckPrerequisites: IsComputerNameValidTitle: Passed

[09:39:33]: Debug: :

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :<![CDATA[CheckPrerequisites: Logic Type:and MemoryCheck-1gbFail: 0CheckPrerequisites: Logic Type:and MemoryCheck-2gbWarn: 0]]>

[09:39:33]: Debug: :

[09:39:33]: Debug: :CheckPrerequisites: memoryCheckTitle: Passed

[09:39:33]: Debug: :

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :<![CDATA[CheckPrerequisites: Logic Type:and NTFSDrive-Fail: 0]]>

[09:39:33]: Debug: :

[09:39:33]: Debug: :CheckPrerequisites: ntfsCheckTitle: Passed

[09:39:33]: Debug: :

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :<![CDATA[CheckPrerequisites: Logic Type:and PendingReboot-Fail: 0]]>

[09:39:33]: Debug: :

[09:39:33]: Debug: :CheckPrerequisites: PendingRebootCheckTitle: Passed

[09:39:33]: Debug: :

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :IsServiceInstalled: RemoteRegistry? True.

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :<![CDATA[Successfully parsed version numbers. Required: 3.1 Actual: 5.0CheckPrerequisites: Logic Type:and WindowsInstallerVersionCheckDelegate-v31: 0]]>

[09:39:33]: Debug: :

[09:39:33]: Debug: :CheckPrerequisites: WindowsInstallerCheckTitle: Passed

[09:39:33]: Debug: :

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :<![CDATA[CheckPrerequisites: Logic Type:and ADCheck-Fail: 0]]>

[09:39:33]: Debug: :

[09:39:33]: Debug: :CheckPrerequisites: ActiveDirectoryCheckTitle: Passed

[09:39:33]: Debug: :

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :<![CDATA[CheckPrerequisites: Logic Type:and AvicodeAgentInstalled-x86: 0CheckPrerequisites: Logic Type:and AvicodeAgentInstalled-x64: 0]]>

[09:39:33]: Debug: :

[09:39:33]: Debug: :CheckPrerequisites: AVIcodeAgentCheck: Passed

[09:39:33]: Debug: :

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :ServiceControlFunctions.IsEnabledAndRunning(): Starting...

[09:39:33]: Debug: :IsServiceInstalled: RemoteRegistry? True.

[09:39:33]: Debug: :ServiceControlFunctions.IsEnabledAndRunning(): Checking second time because first time result was False.

[09:39:33]: Debug: :IsServiceInstalled: RemoteRegistry? True.

[09:39:33]: Debug: :**************************************************

[09:39:33]: Debug: :<![CDATA[CheckPrerequisites: Logic Type:and PassIfWin8Anything: 0CheckPrerequisites: Logic Type:and ServiceCheck-WinRM-enabled: 0CheckPrerequisites: Logic Type:or ServiceCheck-WinRM-running: 2]]>

[09:39:33]: Debug: :

[09:39:33]: Debug: :CheckPrerequisites: RemoteRegistryCheckTitle: Passed

[09:39:33]: Debug: :

[09:39:33]: Debug: :**************************************************

[09:39:33]: Always: :CheckPrerequisites: Return Value 0

[09:39:33]: Always: :Entering Page: AdditionalPrerequisitesPage

[09:39:35]: Always: :Entering Page: ShortEulaPage

[09:39:35]: Always: :Displaying localized EULA for localization: en

[09:39:35]: Always: :Displaying Eula: C:\Users\adminrpaquin\AppData\Local\SCOM\Setup\en\eula_en_notice.rtf

[09:39:37]: Info: :Info:User has agreed to EULA.

[09:39:38]: Always: :Entering Page: SelectManagementServerForReporting

[09:39:51]: Info: :Could not connect to Management Server: DEVSCOM01.local with exception: Threw Exception.Type: System.ApplicationException, Exception Error Code: 0x80131600, Exception.Message: We found 0 servers but expected only 1. This is a fatal error.

[09:39:51]: Info: :StackTrace: at Microsoft.EnterpriseManagement.OperationsManager.Setup.Common.SetupHelpers.GetVersionOfManagementServer(String managementServer)

at Microsoft.EnterpriseManagement.OperationsManager.Setup.Common.SetupHelpers.IsManagementServerCurrentVersion(String managementServer)
at Microsoft.EnterpriseManagement.OperationsManager.Setup.Common.SetupHelpers.CanConnectToManagementGroup(String managementServer)
[09:40:17]: Info: :Info:Management Server matches the release version of setup.
[09:40:17]: Always: :Entering Page: SelectReportingInstance
[09:40:17]: Always: :SQL Server SRS Instance (escaped name) RS_SSRS
[09:40:17]: Info: :Attempting to get the SSRS version from: \\DEVSCOMSQL01\Root\Microsoft\SqlServer\ReportServer\RS_SSRS:__NAMESPACE
[09:40:17]: Debug: :Path is \\DEVSCOMSQL01\Root\Microsoft\SqlServer\ReportServer\RS_SSRS\V15:MSReportServer_Instance
[09:40:17]: Always: :SRS instance on DEVSCOMSQL01\SSRS. Version 15.0.1102.962.
[09:40:17]: Always: :No SRS instances on DEVSCOMSQL01.
[09:40:17]: Info: :Info: DEVSCOMSQL01\SSRS SRS version = 15.0.1102.962
[09:40:17]: Info: :Attempting to check SRS version
[09:40:17]: Info: :Info: DEVSCOMSQL01\SSRS SRS version = 15.0.1102.962
[09:40:17]: Info: :Attempting to check SRS version
[09:40:17]: Info: :Info: DEVSCOMSQL01\SSRS SRS version = 15.0.1102.962
[09:40:20]: Debug: :GetSRSProperties: SRS Server is: DEVSCOMSQL01\SSRS.
[09:40:20]: Always: :GetSRSProperties: SRS Instance is: SSRS
[09:40:20]: Debug: :GetSRSProperties: Actual SRS reg location is: SOFTWARE\Microsoft\Microsoft SQL Server\SSRS\MSSQLServer\CurrentVersion
[09:40:20]: Info: :Attempting to get the SSRS version from: \\DEVSCOMSQL01\Root\Microsoft\SqlServer\ReportServer\RS_SSRS:__NAMESPACE
[09:40:20]: Debug: :GetSRSProperties: SRS DatabaseServerName is DEVSCOMSQL01.
[09:40:20]: Debug: :GetSRSProperties: SRS InstanceName is SSRS.
[09:40:20]: Debug: :GetSRSProperties: SRS DatabaseName is ReportServer.
[09:40:20]: Debug: :GetSRSProperties: SRS Report Server folder is C:\Program Files\Microsoft SQL Server Reporting Services\SSRS\ReportServer.
[09:40:20]: Debug: :GetSRSProperties: SRS Config File is C:\Program Files\Microsoft SQL Server Reporting Services\SSRS\ReportServer\rssrvpolicy.config.
[09:40:20]: Debug: :GetSRSProperties: SRS binary folder is C:\Program Files\Microsoft SQL Server Reporting Services\SSRS\ReportServer\bin.
[09:40:20]: Info: :Attempting to get the SSRS version from: \\DEVSCOMSQL01\Root\Microsoft\SqlServer\ReportServer\RS_SSRS:__NAMESPACE
[09:40:20]: Info: :Info:Found url for given RS instance:DEVSCOMSQL01\SSRS. RS URL:http://DEVSCOMSQL01:80/ReportServer
[09:40:20]: Info: :Info:Found url for given RS instance:DEVSCOMSQL01\SSRS. RS URL:https://devscomsql01.testad.wlu.ca:443/ReportServer
[09:40:20]: Debug: :GetSRSProperties: ReportServer Url is https://devscomsql01.testad.wlu.ca:443/ReportServer.
[09:40:20]: Always: :Reporting URL: https://devscomsql01.testad.wlu.ca:443/ReportServer
[09:40:20]: Info: :Attempting to connect to above URL
[09:40:21]: Always: :Create dummy schedule
[09:40:21]: Always: :Delete dummy schedule
[09:40:21]: Always: :Entering Page: AccountsInformationPage
[09:40:43]: Info: :Info:AccountsInformationPage: In OnNextFinalValidationsDoWork to validate account access.
[09:40:45]: Debug: :MSSQL$scom on server devscomsql01 is in a running state
[09:40:45]: Debug: :Connection was not open. We will try to open it.
[09:40:45]: Debug: :SqlConnectionReady returned True.
[09:40:45]: Info: :Info:Using DB command timeout = 1800 seconds.
[09:40:45]: Info: :Standalone Reporting needs to validate the Data Reader account against the Management Group for clean install.
[09:40:45]: Error: :GetAccountForAProfileFromManagementGroup: No security overrides found for given profile.
[09:40:45]: Info: :Attempting to compare Data Reader to: \
[09:40:45]: Info: :Info:AccountsInformationPage: Async account validation thread returned to UI thread.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.